smart effector crashes into bed. light works



  • I have an anycubic kossel mini. Changed out the electronics to a duet 2 wifi and smart effector. trying to get my config.g file setup. at first I couldn't get the zstop max to work with a probe at the same time. then I'm not sure what I changed but it started actually detecting the probe hitting the bed. after testing the center for several times it would complain that auto calibration had failed because it couldnt move to probe point P0 and I should check my probe radius. my probe radius seemed fine and I was trying to adjust my config.g to see if my sensitivity was off or something and now I can't get the probe to register at all. the green light comes on when I tap the effector, and the connectors and wires look just fine, but the probe just crashes into the bed over and over again.

    my config


  • administrators

    Two likely possibilities:

    1. Z probe configuration incorrect. Please post your config.g.

    2. Output wire from the Smart Effector to the IN pin of the Z probe connector on the Duet is broken.

    When the printer is turned on but idle and the green LED is off, what is the Z probe reading in DWC?



  • config was posted already. the link at the very end of that first post.

    if you mean machine control -> machine status -> sensors -> z-probe then it reads zero at idle


  • administrators

    I found this in your config:

    G31 P100 X0 Y0 Z20 ; Set Z probe trigger value, offset and trigger height

    Z20 is wrong, it tells the firmware that when the probe triggers, the nozzle is 20mm above the bed. So auto calibration might appear to succeed the first time you run it, but after that the nozzle will crash into the bed. Change it to Z-0.1, then test the Z probe as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe. If a tap to the nozzle stops the G30 move, you are ready to try auto calibration again. Change the M558 H parameter to 40 temporarily in case your delta parameters are a long way off to start with.



  • Thanks for the tips. I changed z20 to z-0.1 in the G31 line and changed m558 H to 40, and reset the board. it still crashes into the bed.

    I do note that trigger height has been updated to -0.1 under settings -> machine properties -> Z-probe -> trigger height

    I also double checked the wiring again and it looks solid. it's brand new 18 gauge silicone sleeved wire. The pins are firmly in the connectors and there are no kinks or cuts on the wires.


  • administrators

    Did you run test Z probe test that I linked to?



  • I'm not sure which one on your link you mean. I have the smart effector so that should be the one under dynamic test. if that's what you mean then yes I've run G30 after a home all and it slowly descends into the bed and crashes into it


  • administrators

    @sirus20x6 said in smart effector crashes into bed. light works:

    I'm not sure which one on your link you mean. I have the smart effector so that should be the one under dynamic test. if that's what you mean then yes I've run G30 after a home all and it slowly descends into the bed and crashes into it

    The instructions tell you to trigger the probe before it hits the bed, and to turn off the power if it doesn't stop. For the Smart Effector, this means tapping the underside of the nozzle so that the green LED flashes. This is also covered at https://duet3d.dozuki.com/Wiki/Smart_effector_and_carriage_adapters_for_delta_printer#Section_Commissioning. Does the G30 probing move stop when you do that, or not?

    If it doesn't stop:

    • Run M558 without parameters, and check that the values it reports match the ones in config.g (in particular, probe type 8, not inverted)
    • What firmware version are you running? If it's very old firmware that doesn't support mode 8, use mode 5 (P5 in M558) instead.


  • it does not stop if i tap the probe after a g30. the green light does blink though.

    sneding m558 gives me
    Z Probe type 8, input 0, invert no, dive height 40.0mm, probe speed 1200mm/min, travel speed 6000mm/min, recovery time 0.40 sec, heaters normal, max taps 1, max diff 0.03



  • Software Information
    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.03beta2 (2019-02-16b1)
    WiFi Server Version: 1.23beta1
    Web Interface Version: 1.22.6



  • fixed it! I had a single hair of a wire from the gnd connector on the smart effector end laying across to the next pin, i cleaned it up and dabbed a little liquid electrical tape on the wires coming out of the connector.

    Thanks for your help with the config side of things!


  • administrators

    @sirus20x6 said in smart effector crashes into bed. light works:

    fixed it! I had a single hair of a wire from the gnd connector on the smart effector end laying across to the next pin, i cleaned it up and dabbed a little liquid electrical tape on the wires coming out of the connector.

    Thanks for your help with the config side of things!

    I'm glad you fixed it. I had been thinking that a short between OUT and GND would explain the problem, but it seemed unlikely that you would have one.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.