First T0 in gcode, does not work



  • Firmware 2.02 DWC 2.0.0-RC5

    When I have no tool selected before printing, and I have a T0 in the gcode. The tool is not loaded.

    By cons, if I have my tool loaded before printing, and I have T1 T2, it changes filament.
    This is in the case of my MMU, where I load the filament in tpost0.g


  • administrators

    @nicolab28 said in First T0 in gcode, does not work:

    When I have no tool selected before printing, and I have a T0 in the gcode. The tool is not loaded.

    What exactly do you mean by "is not loaded"? Note, if you haven't homed the printer before you run T0 then the tool change macros will not be run.



  • I mean by charging the filament

    I would have to check, I'm not 100% sure
    but it seems to me that the home is done.

    here is the beginning of my print file
    G90
    M83
    M106 S255
    M140 S130
    M190 S130
    M104 S225 T0
    M109 S225 T0
    G29 S2
    M98 P "GotoPurge.g"
    M98 P "Wipe.g"
    G28 Z; I only redo the z for the G29
    G29
    ; process Tool0
    T0


  • administrators

    Your print file only homes Z. So the T0 command should work fully if and only if you fully home the printer before running the print file.



  • I just retest and with a home made, it does not load the filament, it does not execute tpost0.g

    I had a doubt, because DWC told me that the home was done, after stopping the print. So I redo a test by launching a homeall, without having preloaded the tool.
    And the same, no execution of tpost0.g in the print file

    I also noticed something, it is that after an interruption of a print, the home seems to be still valid, on the other hand, the probing seems to preserve the babystep, whereas I force it to zero in my homez.g with the code M290 R0 S0

    My problem is that I can not do homeall once my tool is loaded because the filament is engaged. I would have to put a T-1, but I have not done it yet. I know it's not perfect.
    But if it's loaded, it's that the homeall has been done, so it works ...
    It may happen that the homeall is not done, and that the filament is not loaded, but I just checked, homeall done with tool not loaded, the T0 of the print file does not launch the tpost0.g

    FYI, I do not do anything in tpre # .g


  • administrators

    Am I right in thinking that you are using M703 within your tpost0.g file, and you are finding that file /filaments/<filament name>/config.g isn't being run? If so, please post the contents of tpost0.g and your filament config file here.

    Do you have any evidence that tpost0.g is being run at all? You can put a M117 command with a message in it to check.



  • No, I do not use filament management

    Here are my macros, I skip the servo macros, gotopurge and wipe

    tpost0.g

    G1 U0
    M98 Ptpost_all.g

    tpost_all.g

    M98 P"GotoPurge.g"

    ;M291 S3 R"Test" P"Press OK to start test"

    M116
    M98 P"SortirServo.g"
    M400
    M98 P"SortirFilament.g"
    M400
    M98 P"RentrerServo.g"
    M400
    G1 E60 F300
    G1 E20 F300
    G1 E-5 F1800
    G1 E2.5 F300
    M400
    G4 S4
    M98 P"Wipe.g"
    G1 E-2 F1800

    SortirFilament.g

    G92 V0
    M574 V2 S1
    G1 V1000 F3600 S1
    M581 E1 S0 T2 C0 ; activate trigger 2 on falling edge
    M582 T2 ; check filament sensor to confirm loading successful
    M581 T2 S-1

    G92 V0
    M574 W2 S1
    G92 W0

    ; methode stall
    ;M574 W2 S3 ; W2 2-> end & S3 3 = motor load detection
    ;M913 W50; r‚duire le courant moteur … 50% pour ‚viter le meulage
    ;M915 W S5 F0; régler les paramêtres de protection contre le décrochage
    ;G1 S1 W2000 F3600; filament d'alimentation rapide dans l'extrudeuse
    ;M913 W100; augmente la puissance moteur

    ; methode capteur

    G1 W2000 F8000 S1
    G92 W0
    G1 W60 F2400
    G92 W0

    ;M581 E1 S0 T2 C0 ; activate trigger 2 on falling edge
    ;M582 T2 ; check filament sensor to confirm loading successful
    ;G92 W0
    ;G1 W-100 F3600
    ;M400
    ;G1 W-100 F600

    G1 E50:50 F300

    G92 W0
    M400

    I tested a T0 directly in the top control bar, and it works well.
    As if when I start printing, he had in memory a T0 already activated. I will test tonight with a sound (M300)


  • administrators

    Do you have a T0 command at the end of config.g? The online configurator gives you the option of inserting one.



  • I just checked, and no, neither in homeall.g



  • I will test tonight by putting a sound in the command tpost0.g
    And I will raise everything, as I will see.



  • it's the M109 S225 T0 the offender



  • he selects me the tool, but not completely



  • @NicoLab28 so a tool needs to be selected so you can heat the Hotend, but, it's too cold to extrude. So my work around is to just let the Hotend heat up at the start then what I do is this

    Start code example;
    Heat up Hotend...
    T-1 P0
    T0
    Start printing....

    I always have a T-1 in my end gcode so the machine is always unloaded when starting


  • administrators

    @nicolab28 said in First T0 in gcode, does not work:

    it's the M109 S225 T0 the offender

    For compatibility with slicers that don't select a tool before heating it (i.e. most of them), if M109 is used with no tool selected then RRF selects the tool. So M109 S225 T0 run with no tool selected should be equivalent to T0 followed by M109 S225 T0. It should still run the tool change files exactly as if you had used the T0 command explicitly - assuming that all axes are flagged as having been homed. But of course the tool won't be hot when the tool change files are run, so commands to extrude or retract filament will probably fail.



  • Thank you gavatron and DC42,

    The problem with the T-1 is that if there is a filament loaded at the beginning of the print, it will unload it.
    For now, I load my tool before,.

    There is a method / trick for heating the hotend without selecting a tool?
    No doubt the use of
    G10 Rxx Sxx
    T0
    in the print file

    M116 at the beginning of tpost # .g (which I already do)



  • That's why I always start unloaded, then load before each print. Much easier


  • administrators

    @nicolab28 said in First T0 in gcode, does not work:

    The problem with the T-1 is that if there is a filament loaded at the beginning of the print, it will unload it.

    You can use T-1 P0 to deselect the tool without running the tool change files, if you don't need any part of the free file run.

    There is a method / trick for heating the hotend without selecting a tool?

    Use T0 P0 to select tool 0 without running any tool change files, then you can heat it.


Log in to reply