Fan plugged on Fan0 doesnt turn on when i print



  • Hi,
    I have an extra fan attached next to my print head that should turn on when the temperature is high. So i plugged it on Fan0 on the duet Wifi. The problem is it never turns on …
    The fan is wired correctly because when i plugged it into "always on fans" it is turning on when i start the duet.
    I guess i am missing a configuration line in my config.g file ?


  • administrators

    Fan0 is the default print cooling fan, and will be off until you use M106 to start it. For example, M106 S255 will run it at full speed.

    If what you are looking for is a thermostatic fan for the hot end heatsink, that is how the Fan1 output is configured by default.



  • Thanks for your answer DC42.
    So i plugged my fan to fan1 as you mentioned. But the fan is turning ON when i turn on the duet wifi, as an always On fan.
    Towards which temperature the fan start to turn on ? I leave in singapore, the average temperature here 30 degrees 😉


  • administrators

    By default Fan1 will turn on whenever any hot end is reading 45c or higher, or when any hot end is in the error state. You may have a different threshold set if you have a M106 P1 command in your config.g file.



  • Thanks DC42, i will check the config.g when i can access back the web interface.
    unfortunately my duet wifi stopped working for some reasons. I can't access the web interface from the usual ip adress.
    To troubleshoot it i plugged it in usb, but the computer doesn't seem to recognize it. Then i unplugged all the wires from it thinking it could be a short circuit, but still when i connect the board to the computer in usb, it doesn't get recognized ….
    This is a picture of it:
    http://imgur.com/a/YbXyY
    Does the Diag Led is alerting that there something wrong?

    Should i try to reset or Erase ? Maybe the microsd broked ?


  • administrators

    The Diag LED shares a pin with the Z probe modulation pin, so its state during normal operation will depend on the Z probe type in your M558 command.

    Even if the SD card isn't read, you should be able to connect via USB. If the port doesn't show up at all on your computer when you connect the USB, try another USB cable - beware of mobile phone USB cables that have only the power pins connected! If it still doesn't work, try erase and re-upload using SAM-BA.



  • Thanks DC42,
    iam worry now. As you mentioned i tried to use different usb cables ( the red one on the picture i use is working properly since i used it to activate the wifi originally) without result. I also tried to erase and then use sam-ba to inject the firmware, but the board doesn't get detected on widows. I opened the device manger and look at the Ports (COM & LPT), but the list doesn't update when i plug the board. i also tried with and without the sd card as well.
    I tried the procedure from :
    https://duet3d.com/wiki/What_to_do_if_your_Duet_or_Duet_WiFi_won%27t_respond
    https://duet3d.com/wiki/Updating_main_firmware
    without success…

    It sound like this board is faulty, DC42 do you think i should send it back ?


  • administrators

    Is the green 3.3V LED on the board lit? Did you hold the Erase button down for at least half a second, then release it? Have you tried a different USB port on your PC?



  • No it's not green anymore, it used to be. But i think when i pressed ERASE it stopped turning green.
    I tried the recovery procedure as described in the documentation several time but without success.
    I made a small video to show you what is happening :
    https://www.youtube.com/watch?v=U_LN9gJqXUc


  • administrators

    Looks like there is no 3.3V supply. I suggest you ask for a replacement board. Are any of the ICs getting hot?


Log in to reply