Smart Effector Probe Setup Issues



  • I just plugged in my smart effector for the first time today, and instead of seeing the green led flash twice it flashes 7 times, pauses, and then repeats. Does anybody know what that means? All of the other hotend components work including the print illumination leds, so I'm pretty sure it's a probe wiring issue but I've checked all of the connectors and leads and haven't found any issues. Any help would be appreciated.


  • administrators

    Flashing 7 times means that the voltage it read from the strain gauge via the amplifier was out of tolerance. It's not unusual to see this when you first power up, but after doing that once or twice it should give the two flashes. If it doesn't stop flashing 7 times, then the strain gauge trace may be damaged and you should ask for a replacement.



  • @dc42 That's very unfortunate. I do have a spare one, but when I plug that in it does the same thing but flashes 6 times. What does that mean?



  • @dc42 any idea what the 6 flashes means? If I need to buy another smart effector it would be great if I could do that today


  • administrators

    @ka15574 said in Smart Effector Probe Setup Issues:

    @dc42 any idea what the 6 flashes means? If I need to buy another smart effector it would be great if I could do that today

    6 flashes means the same as 7 except the sensor output is out of tolerance the other way. It is quite common with the version 2 effector to see 6 or 7 flashes once or twice immediately after power up, and then to get the 2 flashes after the strain gauge amplifier has settled.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.