Wishlist: when idling the steppers also move then to full step.



  • After the idle timeout, when reducing the stepper's current, also move them to the closest full step to eliminate the buzzing sound from the interpolation.

    On my printer the buzzing sound is very noticeable.



  • @zapta Are you sure the buzzing is caused by interpolation? It is easy to prove.

    From the console send M350 N1 to change to whole step micro stepping - where "N" is the axis motor you want to apply it to - so "N" will be either X, Y Z, or E. Then a do small G1 move say 0.1mm so G1 N 0.1. (again substitute "N" for X Y Z or E). In theory as you have changed the micro stepping after setting the steps per mm, then you should get 0.1mm movement and the motor will jump to the nearest whole step. If for some reason, the steps per mm aren't automatically re-calculated, then you'll so 1.6mm movement - hence the reason for using a small number.

    If that works, then you will have proven that moving to a whole step works and as an interim measure, you could encompass those commands in a macro which can be called at any time ( in your slicer post print for example).

    If it doesn't make any difference, then I suggest you search these forums as IIRC there are other ways to reduce motor noise.



  • @zapta You are right that microstep-positions can have audible noise (and each microstep-position has it's own noise-frequency and level - so changing to another microstep could already help).

    You can try to tune the driver settings with the Guide to reduce stand-still noise to see if you can lower the noise. It helped a lot on my machine.



  • @zapta

    I like this idea, because in full-step the holeded position can be also with less current more easily guaranteed, because thanks to the natural magnetic field (most people use hybrid steppers?) that overtakes part of the job current would have to do otherwise I guess to prevent it to reach the next stable position. Or am I wrong? Could that bring down the electricity-bill?

    EDIT: I think I like too many feature-requests 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.