Unable to connect to DWC after startup



  • Hi,
    My Duet Wifi is unable to establish a connection to DWC.
    It did have that problem for a while, in the beginning this was easily solved by just restarting the duet.
    Two days ago that Problem didn´t go away, so I tried a firmware update by putting the files on the SD card and executing over YAT (Which it could establish a connection with) but that failed, so I typed the M997 S0 command in the PanelDue and that worked. It updated the firmware, restarted and then worked for the next two days, so i thought the Problem was fixed.
    But today the same thing came back, I was connected normally and already been printing, then i switched it off to change a stepper cable. switched it back on and no sign of connection. #
    I tried the firmware update again but no luck, since it is already the newest firmware installed.

    When I try the M552 S0 on the PanelDue, it does nothing, and when I do the M552 S1 it says i have to shut off the established connection first ( which S0 should have done).
    YAT can establish a connection (over USB) .

    If i do a M582 on the PanelDue it gives me this

    alt text

    Does anybody have a clue what is going on? Any help would be appreciated
    Thanks
    Max



  • Alright after about 6 hours where I admitted defeat and always used the sd card to transfer the files, the DWC works again. I have not changed a thing.
    What could that be?



  • Can you post your config.g?
    What firmware versions are you using for everything?


  • administrators

    If you send M552 from PanelDue with no parameters, what does it report?



  • At the moment it reports that it is connected to my wifi, but the DWC is working as intended at the moment.
    I will have to check when it doesn´t anymore, it seems to do this with a sort of 2-day interval. Does this have to do with my router frequency hopping?

    0_1553892518756_IMG_2886.JPG


  • administrators

    If you run M122 from Duet Web Control, what WiFi signal strength does it report?

    When you can't connect, are you certain that isn't because your router has assigned the Duet a different IP address?



  • It says
    WiFi signal strength -59dBm, reconnections 0, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0

    A second try said -57 dBm


  • administrators

    @nitrofreak said in Unable to connect to DWC after startup:

    It says
    WiFi signal strength -59dBm, reconnections 0, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0

    A second try said -57 dBm

    That's a reasonable signal strength. My guess is that when you can't connect, the signal strength has dropped. As you suggest, this could be caused by your router frequency hopping. You might like to test which channels work well and configure your router to use one of them always.



  • Okay so it happened again, and i ran M552 from the PanelDue and it said that it was connected to the wifi.
    0_1554084186268_IMG_2921.JPG
    However, no luck connecting to it over DWC.
    It was mid print, so i don´t know if that has anything to do with it.
    I´m really glad that i bought the PanelDue along with the Duet, otherwise with these frequent (2-day cycle) disconnects i would have been helpless if that happens mid print.
    So the question is now, if it is not the Wifi that the Duet suddenly cannot connect to, what could it be?


  • administrators

    Which main and WiFi firmware versions are you running? Recommended is 2.02 (unless you are running 2.03beta) and 1.22 or 1.23.



  • Hi David,
    My firmware version is 2.02(RTOS) (2018-12-24b1) and the WiFi Server version is 1.21, the Web interface version is 1.22.6

    By WiFi firmware version, do you mean the Firmware that runs on my router?
    My DWC now works again. it is remarkably repeatable



  • Ok so i have just updated the Wifi firmware version to 1.22 from the separate .bin file, we will see if that fixes the problem.
    David you may want to check if you surely included the Wifi firmware 1.22 in the Duet2Firmware-2.02a.zip, since i got my Duet at the start of February, and only updated at the start of march.
    My downloaded and unzipped folder included the 1.21 version?


  • administrators

    I have just verified that the Duet2Firmware-2.02a zip file in the Releases area does include DuetWiFiServer.bin version 1.22. But I have now added Duet2Firmware-2.02b.zip which includes DuetWiFiserver.bin version 1.23.



  • Okay so it happened again, this time much earlier than the usual 2-day cycle. Still can´t connect back up, it has been like this for the last 5 hours. So the 1.22 version did not change this. I´ll try updating to 1.23 once it comes back up.
    It´s just weird that, the Duet says it´s connected, so the problem must lie with the PC or router. But when i restart both of them, the problem does not go away?


  • administrators

    Does the router say that the Duet is still connected, or not?



  • @dc42
    Where do i check that?



  • @nitrofreak You'd have to log into the routers configuration page.



  • Ok so it works again and i have updated to Wifiserver 1.23
    I just checked with the router and this is what i got.

    0_1554337039456_router.png

    It says it is connected, but it is no witchcraft since the DWC works also at the moment.
    If i get another disconnect, i will check back if it says the same address, correct?



  • It looks like it says dynamic rather than static. You may be able to tell the router to assign the same IP address every time.



  • Ok so i´ve just had a disconnect, just around the time i was looking around in the router system.

    0_1554339576845_IMG_2983.JPG

    I checked in the router, and the 192.168.0.199 , so my printer, was still marked as connected.
    That disconnect settled itself after a restart though.
    So i tried switching off the duet, and check if it said it was still connected, which it did. It did not disapper for about 5-10 minutes after i had shut the duet down. When i restarted the duet, it was right back there.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.