PID tuning, lesser maximums?



  • So I've spent hours trying to tune, I thought it was all good until I switched to ABS, and thus coming near maximums of temps.
    Tevo tarantula is the base, same heaters. XL bed too.

    Tuning goes ok for the bed, but of course with socks on, Heater 1 and 2 require PWM reductions.
    After all is complete I have the following numbers. (curious about can you set PID setpoint change parameters or load change parameter? or are those informational)

    ;PID TUNES
    ;M307 H0 A112.7 C505.2 D3.2 V12.0 B0
    ;M307 H1 A314.3 C152.7 D3.6 V12.0 B0
    ;M307 H2 A334.2 C187.2 D3.5 V12.0 B0

    Here's an example of my latest bed tune after 2 or 3 other tunes and working with those numbers.
    Heater 0 model: gain 112.7, time constant 505.2, dead time 3.2, max PWM 1.00, calibration voltage 12.0, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P250.3, I6.230, D560.0
    Computed PID parameters for load change: P2

    Now the issue is, setting bed to 110 (max is 120 for the bed iirc, 260 for the hotend) and hotend to 255. Right about the time the bed gets to temp or the same for the hotend in the warming cycle~
    I'll get 'tune was not driven because its heater temperatures were not high enough or it has a heater fault' for the bed, can't recall but I think the same error for the hotends.

    I remove the above M307 commands from config.h, and everything works at the 255/110, np.

    I must be doing something wrong. I also just switched out the tarantula default power supply for a Meanwell 50 amp 12v. Yes I would like to switch to 24v, but it would require a lot of replacements. But I don't believe this is the issue. Though with my previous tunes on the old power supply the 12v V parameter was 12.2-12.3, and the new power supply I've not adjusted and it gets a solid 12.0v on all the new tunes.

    Any thoughts would be greatly appreciated. 🙂 Not entirely sure tuning is even necessary but I'm trying to go the distance!


  • administrators

    @kungpaoshizi said in PID tuning, lesser maximums?:

    tune was not driven because its heater temperatures were not high enough or it has a heater fault

    Please take a screenshot of the DWC Console page to show the exact message, because that one doesn't make sense.



  • @kungpaoshizi That seems fairly straightforward although a little contradictory in places.

    I don't think this is the problem but the first thing to try is to increase the maximum temperatures you have set in config.g (M143).

    I doubt that's the problem though. From what I can make out, basically the bed heater is struggling to reach 110 deg C. So your options are, fit a more powerful heater. Or increase the supply voltage if you can. Or use a lower temperature.

    The contradictory part is in relation to the hot end. You start off by saying quote...........

    "of course with socks on, Heater 1 and 2 require PWM reductions."

    Then you go on to say that you get warning that the tuning failed because the temperature was not high enough.

    Therefore the simple thing to do is not reduce the PWM value, or not reduce it by as much.

    Edit. Sorry David. I was typing the above before you made your comment so I didn't see it.



  • Ya, that's the funny part. The first extruder requires a pwm of .8 and completes without saying it'll get to 400+celsius, the 2nd I haven't used as much and requires .7 pwm before the warning goes away.
    I'll have to get to this after a bit, but I want to say I only removed the first part for a google search, so the message when heating the bed was:
    Heater 0 tune was not driven because its heater temperatures were not high enough or it has a heater fault.

    Doesn't seem to make sense. This isn't top of the line hardware by any means as Tevo cheaps out, but it works. Done 5-10 prints now in abs at the high temps np.
    I guess I can do a M301 H0 to get what's currently loaded?

    Been a long day though so I might be getting the bed and hotend messages mixed up. Thought about bumping up voltage but I haven't seen it dip below 11.9.



  • @kungpaoshizi said in PID tuning, lesser maximums?:

    The first extruder requires a pwm of .8 and completes without saying it'll get to 400+celsius

    Reducing the PWM won't change the true meaning of that warning message. That message is only telling you what temperature the firmware predicts the heater could reach in a failure situation where full power is applied in an uncontrolled manner. Reducing the PWM is irrelevant in a failure situation. The only way to truly mitigate the warning message is to use a lower powered heater, say 20w instead of 30w so that it can never reach such a high temp.

    So I would suggest re-running your PID tune with full PWM power and increasing the max temp limit temporarily to allow the PID tune to complete. You can then reduce it afterwards but you may need to bump it a bit above your max expected printing temp since there will be some overshoot.

    Also ensure that you're starting the PID tune from as close to ambient temps as possible. Also try to duplicate actual print conditions as much as possible. If your print cooling fan will be on during a print, have it on during the tune.



  • So I was unable to get it to come up again, I believe it was an instruction in my startup script for S3D. I issue a generic M109 Sxxx in the script to wait for the nozzle before a prime line, but it was early enough the 2nd extruder wasn't selected, so it was attempting it to the un-used 1st extruder? Specifying now 'T1' followed by the M109 next line.

    Either way I also forgot I did indeed get the 300 celsius thermistor, that may have had something to do with the PWM adjustment to get rid of the warning. As soon as I changed the extruder max to 300 it went away. Same with the bed from 110 preset max to 120.

    Everything is working great now though 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.