Still strange problems with Extrusion



  • Hi There,

    Once again after a lot of testing I am back.

    I fixed a lot of issues on previous posts but not I am having much luck printing...to the point of frustration.

    What I have done so far:

    I replaced the Titan Extruder with a Bondtech BMG - much of the problems disappear for one or two prints.

    On the second print the Bondtech had some sort of stall, and "mushed" the pla filament.. I had to use a hot needle to get it out. In an attempt to try and resolve this I changed from a large bowden set-up mounted on a post to a flying bowden, with a much shorter pipe. Its this that led me to one of three conclusion:

    1. Either I have a configuration problem that's effecting the extruder
    2. I have a problem with the internals of the hot end either not heating up enough to melt the pla and causing a traffic jam or somehow providing resistance
    3. both of the above

    Any help will be greatly appreciated.

    Best,

    Andy

    config.g

    *; Configuration file for Duet Ethernet (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 22 2017 22:56:20 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M665 R150 L397.19 B155 H525 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H5 F500 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    M557 R150 S30 ; Define mesh grid

    ; BL-Touch
    M307 H3 A-1 C-1 D-1 ; reserve pin 21 for M42 or servo use
    M558 P9 X0 Y0 Z0 H30 F2500 T5000 ;P9 is a key BLTouch Value
    G31 P5 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 R150 S30 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards

    M92 X80 Y80 Z80 E830 ;E884 838E1763 Set steps per mm for x16 M92 X160 Y160 Z160 E1763 Set steps per mm for x32
    ;M350 E16 I0 ; Configure microstepping without interpolation
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation

    M566 X2000 Y2000 Z2000 E1500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X3500 Y3500 Z3500 E1500 ; Set maximum speeds (mm/min)
    M201 X1500 Y1500 Z1500 E1500 ; Set accelerations (mm/s^2)
    M906 X1800 Y1800 Z1800 E1600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S285 ; Set maximum heater temperature to 285C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4607 C8.950070e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4725 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    ;M307 H1 A330.8 C243.9 D1.8 B0
    ;M307 H1 A399.2 C249.3 D2.9 S1.00 V24.2 B0

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M207 S1.8 R1.8 F3000 T3000 Z0.5 ; Set FW retraction length and speed
    M572 D0 S0.010 ; Set pressure advance
    ;Pressure Advance M572 D0 S0.04

    ; Network
    M550 PTEVO Little Monster ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous
    M501 Load saved parameters from non-volatile memory*
    0_1553427130756_20190323_194914883_iOS.jpg 0_1553427139617_20190323_194920080_iOS.jpg



  • Make sure your retraction isn't set to long. If it retracts too much, it'll jam in the hotend's cool end.

    Set the stepper current low enough for the extruder to skip steps, instead of stripping/grinding the filament.



  • @tef9 said in Still strange problems with Extrusion:

    M305 P1 T100000 B4725 C0 R4700

    It seems odd to me that your hotend thermistor has a C value of 0. If this is an E3D thermistor cartridge it should be 7.06e-8

    That may explain the inability to adequately melt PLA?

    What does your temperature graph look like?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.