Having trouble setting up bulldog clip offset for homeall



  • so, I got a new piece of glass, and tried to set up an offset for the clips, and now my home z doesn't offset at all. I'm sure I messed up something, but not sure what.

    Here's

    ; bed.g
    ; called to perform automatic bed compensation via G29
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Feb 18 2017 23:41:13 GMT-0500 (Eastern Standard Time)

    ; Clear any bed transform
    M561

    ; Home all axes
    G28

    ; mesh bed leveling
    M557 X40:155 Y0:195 S80

    and here's

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Feb 18 2017 23:41:13 GMT-0500 (Eastern Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X40 Y0 Z0 S1 ; Set axis minima
    M208 X155 Y200 Z260 S0 ; Set axis maxima

    and here's

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Feb 18 2017 23:41:13 GMT-0500 (Eastern Standard Time)

    ; Lift Z relatively to current position
    G91
    G1 Z5 F8000

    ; Back to absolute positioning
    G90

    ; Go to first bed probe point and home the Z axis
    G1 X40 Y0 F8000
    M280 P3 S10 I1
    G30
    M280 P3 S90 I1

    ; Uncomment the following lines to lift Z after probing
    G91
    G1 Z5 F100
    G90

    any input is appreciated



  • ok, I think I got it figured out

    Old
    M208 X40 Y0 Z0 S1 ; Set axis minima

    New
    M208 X-40 Y0 Z0 S1 ; Set axis minima


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.