short-to-ground reported by driver(s) 5 6 7 8



  • Versions of things:

    • Duet 2 WiFi H/W v1.03 F/W: 2.03beta3 (2019-03-25b6)
    • Duet WiFi Server Version: 1.23
    • DueX5 (H/W V0.9a)
    • Duet Web Control 2.0.0-RC6

    An RS Components Mean Well ERPF-400-24, wired up to an older Duet 2 Wifi 1.03 and a new Duex5 V0.9a (both purchased from Think3DPrint3D) and commissioning a CoreXY (RailCore II 300ZLT)

    Wiring - pic.
    Duet and Duex5 are mounted on nylon inserts and is clear underneath - pic

    Hooked via USB, web interface and system responds normally.
    I've used the stock github config.g and the Project R3D kit config which I know more people have used and is very similar bar the way the steppers move forwards and backwards.

    The Problem: When plugged in with nothing but power into the Duet & Duex5 as shown, the Duet powers up and I can access the web interface, but I get the following errors constantly

    "Error: short-to-ground reported by driver(s) 5 6 7 8" and
    "Error: over temperature shutdown reported by driver(s) 5 6 7 8" - pic

    I've examined the back of the board, I can see no obvious signs of damage or misplaced solder.

    Your thoughts and input are appreciated.


  • administrators

    Are you sure it's not reporting the same error on driver 9 too?

    Run M122 and see what driver status is reported for the 5 drivers on the DueX5. My guess is that you will find all the status bits set. That error is normally caused by one of the following:

    • DueX5 does not have VIN power. Check that you are getting VIN voltage between the screws of the VIN terminal block on the DueX5.
    • SPI signal from the DueX drivers is not feeding back to the Duet through the ribbon cable. Turn off power and check that the ribbon cable is seated correctly at both ends. Also check the soldering of the 50-way connectors on both boards (they are wave-soldered, so problems are rare).


  • David,

    Thank you for your advice!

    I double checked the power, re-seated everything again and examined and re-seated the ribbon cable.

    When I turned back on it worked, so it was definitely one of these things. Apologies for not testing individually 🙂 Solved!

    Are you sure it's not reporting the same error on driver 9 too?

    It didn't report driver 9 , as you can see in the original screenshots - possibly because my config.g doesn't reference it?)


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.