Extruder compensation on bed mesh level?



  • Hello all,

    I installed a Precision Piezo 27mm (hot end mounted) on my custom cartesian printer.

    I’ve got everything setup just fine (I believe), the mesh bed level runs each time before the print starts, the Z height is proper, etc.

    The extruder primes great on the edge of the bed, it also does the brim and the initial holes and outer border perfectly.

    Then, throughout the layers, it misses quite a bit of material. First layers, infill, top layers. It’s boggling my mind. I can physically see the extruder motor not moving during certain points on each layer.

    I’ve tried adjusting the steps/mm on the extruder, flow rate, multipliers, etc.

    The Z height seems to adjust as necessary for the bed leveling throughout each layer, but it seems as though the extruder feed is being toyed with as well. Maybe this is supposed to happen, but I can’t find anything through my research that confirms this, or that says it’s an adjustment.

    I had near-perfect prints before this, and now I’m left scratching my head. If this is normal for the extruder feed rate to be adjusted through the mesh bed leveling, can it be disabled and just left for the Z-height to be compensated throughout the layers?

    Any help is appreciated!!!


  • administrators

    Mesh bed compensation does not affect extrusion, although ideally it would if bed compensation taper is in effect.



  • Thank you for the reply!

    Is there a way to disable bed compensation taper to check and see if that is my issue? I see that M376 allows me to set it, but not sure about disabling it or if it's possible. Or should I just set it to a super high value to try and override it?


  • administrators

    Bed compensation taper is disabled by default. Send M376 without parameters to check.



  • Thank you, I gave that a shot. It says it is not enabled.

    If nothing else was adjusted or changed before the installation of the piezo and the enabling of the mesh be leveling, any idea what could be causing this given what I've already mentioned I tried? I know it seems like a noob print, but literally everything was spot on before this.

    Thanks again for the help!

    0_1554327986272_IMG_4640.jpg



  • Does it extrude nicely into free air?
    Have you tried doing a cold pull? It appears to be clogged.



  • Thanks for the reply!

    Yep, that was one of my thoughts too.. so I checked the nozzle, and even changed it out. No clogging at all.

    I can do a 30mm extrude at a high rate and the filament shoots out no problem at normal temps.



  • Can you post your config and the gcode file that does this?



  • Actually, I spent all last night trying everything imaginable and finally I got it figured out. Somehow, the spring that tensions the filament to the extruder gear settled in or got soft at the same time I switched over to the carriage I made to house the Precision Piezo. This was causing the extruder gear to slip on the filament when it needed to feed quicker, but was still fine at slower speeds.

    I chased my tail a little bit so I had to bring all the other settings back to normal once the tension was fixed, but now everything is working great.

    Thanks for everyone's help, and sorry for wasting your time 🙂 On the plus side, I learned quite a bit by going through everything to try and figure it out.


Log in to reply