Using Slic3r with Tool Changer



  • I am developing my Tool Changer like E3D machine.
    Using Slic3r PE.
    Trying to print only with tool T3

    The Slic3r creates...

    M107
    M190 S65 ; set bed temperature and wait for it to be reached
    M104 S200 T3 ; set temperature

    At this point T3 is not selected as the operational tool

    My start code...
    G28 ; home all axes
    G1 Z15 F5000 ; lift nozzle

    Then Slic3r puts in

    M109 S200 T3 ; set temperature and wait for it to be reached

    T3 is now selected as the operational tool.

    However no T3 macros have been run to get the tool. So cannot print.

    Any suggestions as the correct way to resolve this?

    Thanks for any help.


  • administrators

    The tool change macros should be run provided that the firmware considers that the machine has been homed when the M109 T3 command is executed, and tool 3 was not already selected. Did the G28 succeed?

    Which firmware version are you running?



  • Thankyou for reply

    I ran the following in console after just powering up machine so not in homed state.
    Here is log

    12:58:22: T: Tool 3 is selected So tool is selected by M109 command but no macro's run.
    12:58:04: M109 S200 T3
    12:57:31: T: No tool is selected
    12:57:23: G1 Z15 F5000 Bed moves OK
    12:57:01: T: No tool is selected
    12:56:40: G28 All homes OK
    12:55:54: T: No tool is selected
    12:55:47: M104 S200 T3
    12:55:14: T: No tool is selected
    12:54:53: M190 S40
    12:54:32: M107
    12:54:01: Message Log cleared!

    Firmware details.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6


  • administrators

    If you send T3 instead of sending the M109 T3 command, do the tool change macros run?



  • Hi,
    Repeated the previous sequence exactly the same except replaced

    M109 S200 T3

    with

    T3

    Yes the macros run and it gets the tool.



  • The documentation for M109 says if the T command is used the tool is selected (slic3r behaviour). By implication although not explicitly stated I would expect the pre and post macros to be run.
    So is the a bug?

    Also when I cancel a print no macros are not run to deselect the tool and yet the status is then no tools selected.

    I have in cancel.g
    M0
    T-1
    And yet the macros are not run.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.