"Solved" Heater 0 fault its been 2 weeks



  • I heat to annoy anyone but am really stuck her

    i have cr-10 with the duet wifi i managed to make everything works despite my poor electronic skill and my language capability

    bed tmp works great and run hotend dose not
    i have tried every configuration and no luck and i have also checked the vssa and gnd reed less the 5 ohm then i checked the wires and everything seems ok

    on the web interface the reding i get from the bed and the hotend is the same numbers but its actually the bed temperature only and when i disable the bed i get 2000.0C from the heater

    made so many swaps between them no different
    heter E0
    thermister E0

    3_1554720347941_4.PNG 2_1554720347941_3.PNG 1_1554720347940_2.PNG 0_1554720347909_1.PNG

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    thanks in advance for any help



  • check the resistance of the thermistor with a multimeter. 2000 means its disconnected. so it might be broken.

    but post your complete config



  • @d7em67 It looks you might have 2 problems. As @Veti said above, a reading of 2000 deg C usually means that the thermistor channel is showing open circuit. But the other problem is related to the unknown temperature sensor channel message and the fact that only one heater is being displayed. Have you by any chance assigned heater 0 to a tool rather than heater 1? If you only use one tool, one extruder and one heater, then you tool definition should be something like M563 P0 D0 H1. If it's H0, then you have assigned the bed heater to the hot end.

    So please post your complete config.g file and also the config-override.g file if you use it.



  • literally i can't say thank u enough 0_1554760041382_5.PNG

    number :1: was missing



  • @d7em67 Glad that worked for you. Can you now mark this thread as solved. The easiest way to do that is to edit the title of the first post and just add the word "Solved"


Log in to reply