Your Duet rejected the HTTP request: page not found



  • Hi out there, I read through several (almost all) of the threads that mention this error in it and can't seem to diagnose what the error is with my duet. I am taking a Duet Ethernet from a custom printer over to my Anet A8 (I know, tad overkill but the Anet's board bricked and I have this extra Duet laying around). While following all of the usual setup process I keep getting the "Your Duet rejected the HTTP request: page not found" whenever I try to connect to the WebControl. I have updated all the firmware (in the correct order -per the instructions on duet3d.dozuki.com). I can connect to the Duet through the YAT terminal and have sent these commands in this order: M552 M39 M502 M21 M503 M122 (see screen shots below for results)
    0_1554747463102_02e0aa76-ffd7-4611-b4b4-adc6244ad854-image.png
    0_1554747503343_7fa63d59-7440-4842-832c-9dd00a0b9205-image.png
    0_1554747528635_9302e764-1fd2-4768-872c-38744d7a5d92-image.png
    0_1554747562681_4af27adb-18be-4c41-90dc-69b1f48d3f75-image.png
    0_1554747593088_0537ed16-d0fa-435f-b462-49e8317b19ca-image.png
    0_1554747663005_719bff70-d74c-4d34-85b8-6ecb8f9daaa4-image.png
    0_1554747682867_75ada10c-5d4d-46ca-801e-e20e77acbac0-image.png

    Any help or advice on this is greatly appreciated.

    Thank you,
    Ari



  • I also tried running M20, it showed a bunch of files yesterday when I tried it but today says NONE in response so I am going to try to flash the files over again and keep this thread updated if that fixes the issue.

    • Update: when I take the SD card off the duet, the computer still shows that the SD card has all the config files so I wiped the SD card and followed the instructions again for flashing the files onto the SD card (found at https://github.com/T3P3/Duet/tree/master/Duet2/SD Card Contents) . When I run M20 now it gives me:

    M20
    Begin file list
    test.g
    End file list
    ok

    0_1554751602091_71acad53-bfd6-4fe2-9ba3-2602ca83c870-image.png

    I also added the custom configuration for the Anet from the reprap config tool into the sys folder. I can upload what is in each of the folders but it seems that I have missed a critical step or download but I cannot find what it is, or why is wont connect to the WebControl



  • UPDATE FIXED: Not entirely sure what was going on but I felt comfortable enough with the process to factory reset the board (hit erase). I then reflashed the 2.02 firmware found on https://github.com/dc42/RepRapFirmware/releases using BOSSA then reformatted my SD card and flashed the contents from https://github.com/T3P3/Duet/tree/master/Duet2/SD Card Contents. Before testing it I did use the configuration tool to generate the config files for my Anet A8 and put those on the SD card - I had to make sure the SD card was initialized using
    M21 in the YAT terminal but I was able to get the WebControl working. One thing I did notice was that I had to update the drivers on my computer so that it would recognize the Duet board as "Duet2WifiorDuet2Ethernet3Dprintercontrolelectronics" versus "USB Serial Device COM_"


  • administrators

    I glad you solved it. The usual reason for the original error message you had is that the Duet was unable to read the web files from the /www folder on the SD card.



  • @dc42 How to solve this for those who are not willing to spend hours reflashing boards for a simple update? Mine is also down now for no reason. Have you guys done any testing before you released that firmware?



  • This post is deleted!


  • @vlad when you plug the board into the computer via the micro usb port on the duet what does it show up in your device manager as? Something like "USB Serial Device COM_"?



  • @aplanetrider it's an old topic, that board is already somewhere in a landfill actually. It was out of warranty and failed, also assembly quality was pretty horrible which I showed to David. I just took a loss already. I also found out that I actually DID NOT feed 5V into it, as I double checked all PAD7 pins, and 5V jumper was not even present, so I have no idea what failed there and especially why. Before the idea was that I fried it by feeding 5V, but that turned out to be incorrect int he end.



  • @vlad Oh gotcha, I apologize for the delay- I am just an end user of these boards for four 3D printers that we have at work and I don't check on here very often but try to help others out if I can! Bummer to hear that board didn't work out, but good luck on your future 3D printing adventures!



  • @aplanetrider well I bought DUET2 at matterhackers. It finally works. Just lost $180 on a first one, which is sad. Decided to not connect screen to it anymore to avoid burning again. Even not connecting the screen via normal USB anymore. Who knows how this board is built, documentation on that is very poor. But with that said, it works fine with web interface, screen is almost not needed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.