A little bit of guidance on connecting fans please



  • Looking at the wiring diagrams is not as straight forward as many say. Connecting up a fan incorrectly can easily blow the MOFSET so a little bit more respect on how to do it right is kinda needed.

    The diagram describes the PWM connections as :
    Fan 0 (left pin) and V_Fan (right pin)
    Fan 1 (left pin) and V_Fan (right pin)
    Fan 2 (left pin) and V_Fan (right pin)

    Based on the two "Always on" fan terminals orientation it is easy to assume that the Fan0, Fan1 and fan2 pins are the GND connections to the fan. Yet the same label for the PWM terminals lead one to assume the right side pins are the GND.
    Someone PLEASE tell me which is which!



  • The negative pin is the pin that is switched on and off for the PWM fans.

    The labels are actually "Fan1-" etc. note the minus sign.

    The right pin is V_FAN, as in positive.

    Left pin -- black wire, negative, GND. Right pin -- red wire, positive, V_FAN voltage (as selected by jumper)



  • @bot Thanks, I got it. Lets hope the MOFSETS do not blow.



  • I have my fingers crossed for you! It's always nerve-wracking flipping the switch for the first time.

    My philosophy for the printer I just built was to be extra slow and careful at every step. It took me three years to design and build, but when it came time to power it up for the first time I had no hesitation. I knew that I had been very diligent and informed at every step of the way.

    It seems you are the same way: careful and deliberate. I'm sure your printer will be excellent.

    Welcome to the forum!



  • @bot Thanks...
    I turned them on and they do not seem to work. They act like there's not enough power for them. They are 24 volt and the diagrams says it runs 5 volts.



  • The way the Duets come configured (via jumper on the board) is to use the VIN voltage for the fans, so if you're using 24 V they should be getting 24 V.

    Are you commanding them to 100% via gcode or web interface or LCD panel? Or are they coming on right at startup?

    The RRF config tool has a weird behaviour where it defaults to setting PWM fans to the value that the tool says is for "minimum PWM".

    In your config.g, on your fan lines, if there is any S parameter other than 0 it is incorrect (unless the fan is supposed to be on by default).

    Since the RRF Config tool defaults to telling fans to go on at 30%, and 30% is sometimes insufficient to drive fans, I suggest you ensure the fan is set to full PWM.

    Post your config.g file or the fan section if possible.


  • administrators

    Test the fans by plugging them into one of the Always On fan connectors first. That way, if you have miswired them then the fuse will blow, which you can replace. When you have the fans working, you can move them to the controlled fan outputs, which have the same polarity as the always-on outputs.



  • @dc42 Wow! REALLY good advice! (Actually I think all the advice here is awesome) I would suggest that this tip be on the page that describes how to wire up the fans!
    Thank you to bot too!



  • @bot
    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on



  • @andy-cohen said in A little bit of guidance on connecting fans please:

    @bot
    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    It's exactly as I guessed. The config tool for some reasons puts the "S0.3" parameter which sets the fan to 30% speed at startup. The RRF Config tool has an error where it sets the "S" parameter instead of the "L" parameter for the option that says "Minimum PWM."

    Remove the S parameter entirely from that first command with S0.3. The other fan may be configured correctly but you'll have to determine this. The other command may need the S1 command, so do not remove it unless you're sure of what you're doing.

    For a part cooling (downward) fan, the S parameter is used to set its speed. A part cooling fan typically should not be spinning upon startup. The S0.3 is commanding it to 30%, which seems to be just slightly too small of a value for your fan.



  • Nothing.
    Way too confusing and I bet I blew the MOFSETs.



  • @andy-cohen OK... Nothing. Is it 1 modest for ALL 3???



  • @andy-cohen WT!?!
    Now it works!
    I wonder what that was about?



  • How exactly did you get it working and what was happening when it wasn't working?

    How are you setting the speeds of the fan? Via LCD panel? Web interface?


  • administrators

    @bot said in A little bit of guidance on connecting fans please:

    It's exactly as I guessed. The config tool for some reasons puts the "S0.3" parameter which sets the fan to 30% speed at startup. The RRF Config tool has an error where it sets the "S" parameter instead of the "L" parameter for the option that says "Minimum PWM."

    Thanks for reporting this. I'll get it fixed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.