BL Touch issues



  • I like others, possibly, purchased BL Touches to help get a perfect layer. I have an Ender 3 Pro.
    I have gone throught the setup countless times as mentioned in another thread and thought I nailed it, using old school manual leveling.

    0_1554885036496_IMG_20190410_092417.jpg
    So printing today i noticed lines in the skirt and adjusted Baby steps and am currently at -0.080mm which has helped in getting the 'Squish'
    Am i doing something wrong, have I messed up my temp settings when I went to the Maestro?
    Or is it my G31 P500 X-47 Y-10 Z0.87 line in my config.g?
    0_1554885374059_config.g

    I used to get really good layers with the Creality Board, but i hated the noise from the steppers and wanted to learn more so i bought the Maestro.

    Any guidance would be appreciated.



  • first check repeatability using this: https://forum.duet3d.com/topic/6962/m48-measure-z-probe-repeatability-and-print-to-serial-output/4

    also bltouch are sensitive to interference.
    so while probing the heaters and fans should be off.



  • Thanks @Veti , I will give this a try.



  • So i ran the macro and these are my results

    M292
    G32 bed probe heights: -0.087 -0.105 -0.098 -0.103 -0.100 -0.105 -0.098 -0.113 -0.093 -0.113, mean -0.101, deviation from mean 0.008

    Do I need to do anything?

    Thanks again.


  • administrators

    @paulhew said in BL Touch issues:

    So i ran the macro and these are my results

    M292
    G32 bed probe heights: -0.087 -0.105 -0.098 -0.103 -0.100 -0.105 -0.098 -0.113 -0.093 -0.113, mean -0.101, deviation from mean 0.008

    Do I need to do anything?

    Thanks again.

    You should reduce the trigger height setting (G31 Z parameter) by 0.1mm to get rid of that -0.1mm offset, but the deviation is low, so other than that you are good to go.



  • Thanks DC42
    So I have redone all of the calibration, piece of paper under nozzle, reset Z axis, Up a bit etc.

    After running a auto compensation i lower the nozzle to what the duet thinks is 0 on the Z axis to a piece of paper and the nozzle still does not touch, it is about 0.7mm off, i measured it with a bit of card and a vernier.
    0_1554934861538_IMG_20190410_231952.jpg
    Hopefully you can see the panel indicating Z0.00 and see the card and paper, i could probably get another piece of paper in there!
    What am i missing please, i have been at this all day again, to no avail.

    Here is the Z section from my config.g I am running a Maestro board.

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P9 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-47 Y-10 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:220 Y15:220 S20 ; Define mesh grid

    Thank you again.



  • I assume you've used this to find your trigger height?

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • Morning,
    Yes i did follow it to the letter.
    At point 6. I actually manually deployed the probe using M280 P64 S10 from the 'Connecting Z-Probe' guide THEN used G30 S-1
    I think this is where I have gone wrong as G30 S-1 also deploys the probe.
    Baby steps are at 0.020mm for this print.

    Thank you all again.



  • @paulhew said in BL Touch issues:

    G31 P500 X-47 Y-10 Z0

    If you are off by 0.7mm then you did not update your z offset correctly.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.