Gcode files: asterisked out, constantly loading, can't print.



  • Printed successfully, attempted to upload another file, it uploads and I hit OK, then the gcodes directory comes back looking like this -

    http://i.imgur.com/Vx0cNL7.jpg

    Tried m999, tried powering off for several minutes, tried reseating the sd card with power off, tried reinstalling the main firmware.

    I can still upload files (Which do the same thing and can't be deleted.) and create new directories (Which I can delete.)

    If I mouse over the gcode directory piece of the page my mouse cursor switches over to a busy spinner.

    So I guess my question is "What the heck?!?!"



  • I could be wrong but seem to recall I had something similar a while back which turned out to be a dodgy file name. Maybe it's the apostrophe that DWC doesn't like? In my case, renaming the files fixed the problem but it was a long time ago so I can't be sure that my issue was the same as yours.



  • @deckingman:

    I could be wrong but seem to recall I had something similar a while back which turned out to be a dodgy file name. Maybe it's the apostrophe that DWC doesn't like? In my case, renaming the files fixed the problem but it was a long time ago so I can't be sure that my issue was the same as yours.

    Would that cause the problem for the whole directory?

    "testcube_20mm.gcode" is doing the same thing.

    If so, do I need to put the SD card into a reader and manually delete?

    EDIT: HAHA! You fixed it! Thanks so much!


  • administrators

    I'm glad you solved it. Which Duet firmware and DWC versions are you running? I believe that bug was fixed recently.


Log in to reply