Driving Servo Motor with Duet3d



  • Hello Everyone!

    I have a duet3d driven cartesian printer which worked superfine with high quality prints using stepper motor.
    Recently i switched to servo motor (JMC IHSV57 integrated AC servo motor). I have some problems driving the head due to the parameters.

    0_1555146633001_04261f02-d4cf-46fb-a213-3fe86df014e9-grafik.png

    Can someone help me with the duet parameters in M569 command with the above graph ?

    currently i use: M569 P7 S0 R1 T2.5:2.5:7:0

    The motor moves smoothly but the position feedback is high and the overall movement of the head is not normal. It always tries to correct the position and if i give another command for movement, the motor stops because of driver overload as the previous correction of position is not completed yet.

    Has anyone used these motors with duet before ?
    Thanks for the help.

    Cheers,
    Phani



  • Snap of my config file:

    ; Drives
    M584 X7 Y5 Z8 ; To define new drives
    M569 P7 S0 R1 T2.5:2.5:5:0 ; Drive 7
    M350 X1 Y1 Z1 I0 ; Configure microstepping without interpolation

    M92 X200 Y97 Z4000 E94:94 ; Set steps per mm

    M566 X2000 Y80 Z15 E20:20 ; Set maximum instantaneous speed changes (mm/min) - Jerk speed
    M203 X4000 Y150 Z300 E9000:9000 ; Set maximum speeds (mm/min)
    M201 X1000 Y40 Z250 E1000:1000 ; Set accelerations (mm/s^2)

    Any Suggestion for correction ?



  • @3d_druck Hey it might be too late(könnte auch Deutsch ^^)?!?. Have you set the perimeters right? The servos show some weeeeird behaviour if the perimeters arent set right! And the pulsewidth on my machine is 4ms. Everything under 4ms wasnt working at all.
    My settings: M569 P5 S0 T4:4:8:0


Log in to reply