Babystepping - confusion..



  • *PanelDue 1.23 kinda solved my issues with the babystepping arrows)

    Anyways, I'm at a loss here, after having made some prints I find myself unable to get plastic anywhere near the bed. I've adjusted the Z height in the config, I can repeatedly move the bed to Z0 and just barely get drag on the piece of paper.

    One thing at the time, after seeing changes were made in 2.03b3 I updated and tried it. To me it seems even worse.

    I do G28 + G0 X60 Y60 Z0. Dial indicator reads 0.3. I apply -0.3 babystepping. Dial indicator reads 0.

    I repeat G28 + G0 X60 Y60 Z0. Dial indicator reads 0.7, I apply -0.7 baby stepping, Dial indicator reads 0.

    I repeat G28 + G0 X60 Y60 Z0. Dial indicator reads 1.0 .. and so on.

    Is this the intended behaviour?



  • How are you homing? What is your probe?

    Babystepping is cleared after homing or power cycling, so that part makes sense.

    Have you tested the repeatability of your probe?

    Is it always increasing like that?



  • Homing is against a (mechanical) z-max limit switch. (at the bottom of the Z travel for the bed).

    Only have test and dial indicators made from the finest Chinesium, and the homing seems to pretty spot on as far as I can tell/measure https://photos.app.goo.gl/YzgsCPNW44rZfpsU7

    To be honest I'm not sure if its always like that, or if that was after i flashed 2.03 beta 3. It just seems to me the baby stepping isn't actually cleared from anything but the display, and keeps compounding the error for every home.

    Anoying thing is I only need a few prints so I can mount a new high power, and adjustable bed ... but thanks to Mr Murphy that'll have to wait:D



  • May be worth reverting to 2.02 to rerun the tests to see if it behaves the same or not.



  • @phaedrux homing doesn't clear baby-steps. Only if your homing script has that added.



  • Homing is pretty basic. (included under)

    But if I ask the printer to home after having applied babystepping, the asking it to go to Z0 will stop it at Z1 if I had 1mm babystepping before homing, so there is some sort of weirdness going on related to babystepping.

    I'll try to re-run the test and revert to 2.02 and compare, might be after easter.

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 08 2019 19:32:08 GMT+0100 (Central European Standard Time)
    G91                     ; relative positioning
    M300 S300 P1500		; beep
    G1 S1 Z3 F300		; drop bed/Z if possible (if not parked at switch)
    M300 S1500 P500		; beep
    G1 S1 X-150 Y150 Z150 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 S2 X3 Y-3 Z-3 F6000      ; back all axis off 3mm to release endstops
    G1 S1 X-150 Y150 Z150 F300  ; move slowly to X, Y and Z axis endstops once more (second pass)
    G90                     ; absolute positioning
    


  • @gnydick said in Babystepping - confusion..:

    @phaedrux homing doesn't clear baby-steps. Only if your homing script has that added.

    Of course, you're right. Sorry for adding to the confusion.

    Here's the source of my confusion:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M290_Baby_stepping

    In RepRapFirmware 1.19 and earlier, the babystepping offset is reset to zero when the printer is homed or the bed is probed. In RepRapFirmware 1.21 and later, homing and bed probing don't reset babystepping, but you can reset it explicitly using M290 R0 S0.



  • This post is deleted!

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.