Connect issues on a specific computer after upgrading to Wifi

  • Hi,

    I'm having an issue connecting to my new Wifi which has been upgraded from a 0.8.5. Chrome connections seem to reboot the Wifiserver with the explanation being either Exception or Watchdog. This computer was the exclusive computer used when the printer was set up with the 0.8.5 and never experienced this issue. I can ping the Wifi from this computer and can pull up the server from an iPad with Safari and from another computer with Edge. I have tried edge to see if this is specifically wrong with my install of Chrome and it doesn't load up either.

  • I have a similar issue, Mine is a new install. I can access Duet Wifi from my iPhone, iPad and my Son's laptop (using Chrome). When I try from my Desktop the browser page does not load. Sometimes it will change the tab title (so it does receive some data from Duet). Other times nothing.

    Tried uppgrading firmware (all three). Upgrade went fine. Seems to crash the Wifiserver less often, but still does not work from my desktop.

    I can ping the Duet from my desktop. Both are on the same sub-net. Have tried Chrome/Firefox/Edge from my desktop.

    It usually reboots the Wifiserver with and Exception.

    Wifiserver reports signal strength of -47.


  • administrators

    We've had one other report of the wifi server crashing repeatedly. In that case the board worked fine on a home network but crashed when connected to a corporate network.

    Unfortunately this problem is impossible to track down because I don't know how to reproduce it. I have a major rewrite of the wifi server code close to the top of my priority list, which I hope will resolve this issue.

  • Hi David,

    I'm most definitely not on a corporate network. Just for FYI in case it helps, I changed the MAC address in the config.g thinking maybe my router was holding on to something from the old 0.8.5 hardware, updated router firmware, and deleted the reservation that I added. Nothing is helping, but, I figured you should know.

    Thank you.

  • Well, I am not on a 'corporate' network, but do use the same router (mikrotik) as we use at office and datacenter. There are 3 sub-nets in the house (hard wired PCs/wireless stuff/entertainment equipment) and a permanent VPN to the office.

    But with the duet and PC on the same subnet, it really should not have anything to do with the router/network topo.

    If you have some alpha code you want tested, I am happy to be a test mule… Can easily setup routed/un-routed/NAT/etc access for testing.

  • I upgraded to 1.19.2 last night. It FIXED this problem which I have had consistently since starting to use my Duet Wifi in early 2017.

  • administrators

    Frank, thanks alot for the feedback and for your patience!

  • Wasn't really a problem. I have an iPad I just leave by the printer. Phone works fine too.

    I know a few of us had this problem and most did not.


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.