Z probe not triggering



  • Hi all
    I have just built a Delta 3d printer. I am completely new to the world of 3d printing. I am using a Duet wifi.

    I have every thing wired up and I have used the RRF config utillity and uploaded the files to Duet and when I press the Home all button the 3 axis motors work and move to home position nicely.

    However, when I press the Auto Delta Calibration button I immediately get the message Error Z probe was not triggered during probing move. The axis motors don't move a millimetre from home.

    My Z probe is a micro switch. At rest the z probe reads zero on screen and when I manually close the switch it reads 1000. The switch is wired to the EO end stop connector on the duet.

    Have I got something wired wrong? or some setting wrong.

    Here is my config.g
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Apr 19 2019 16:08:59 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M665 R305 L270 B275 H315 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 P"Polygon2060" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Hey You. Stay Off My Wifi!!!" P"*********" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E147.32 ; Set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X19999.80 Y19999.80 Z19999.80 E3600.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E800.00 I60 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P4 H30 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    M558 H30 ;*** Remove this line after delta calibration has been done and new delta parameters have been saved
    G31 P500 X0 Y0 Z17 ; Set Z probe trigger value, offset and trigger height
    M556 S50 X0 Y0 Z0 ; Set orthogonal axis compensation parameters
    M557 R275 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory

    I have searched and read posts relating to this error but they have not been helpful to me.
    Any help would be welcome
    Thanks





  • @aidar thanks for your reply. I will check tomorrow as I have now resorted to Gin & tonic to cool the melted bain cells.



  • I copied the example you refered to and deleted the M401 & M402 commands as my probe is manually deployed.
    I still get exactly the same result with same error.

    Here is my bed.g
    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G28 ; home the printer

    ;''' Probe the bed and do 6-factor auto calibration'''
    G30 P0 X-73.53 Y-42.45 Z-99999 ; X tower
    G30 P1 X0 Y-85 Z-99999 ; between X and Y towers
    G30 P2 X73.53 Y-42.45 Z-99999 ; Y tower
    G30 P3 X73.53 Y20 Z-99999 ; between Y and Z towers
    G30 P4 X0 Y67 Z-99999 ; Z tower
    G30 P5 X-73.53 Y20 Z-99999 ; between Z and X towers
    G30 P6 X-36.8 Y-21.25 Z-99999 ; half way to X tower
    G30 P7 X36.8 Y-21.25 Z-99999 ; half way to Y tower
    G30 P8 X0 Y42.5 Z-99999 ; half way to Z tower
    G30 P9 X0 Y0 Z-99999 S6 ; centre, and auto-calibrate 6 factors

    G1 X0 Y0 Z150 F15000 ; get the head out of the way of the bed

    Where do I look next?
    Thanks



  • I solved this problem. Further reading I discovered that in my M665 settings I had entered diameters instead of radii. I changed those and immediately I was able to initiate auto callibration.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.