Tronxy X5ST 500 configure to Duet Wifi 2



  • Hello All and Happy 420!

    I bought and assembled at Tronxy X5ST 500. (500x500x600) I got the better part of 40 hours in this build and am stuck. I upgraded my board to a Duet Wifi 2.

    I was able to successfully connected to the board and I can control the movement of my x and Y axis. The Z axis seems to move up okay and down intermittently. It does not home properly. It just moves up a little no matter where it begins. I can’t home all correctly. I am unable to print. When I send a Gcode print file the x and y move how they should but the z is not in place and no filament is coming out. I believe this is a configuration issue. I followed the configuration instructions for a core xy printer on the duet site. Any advice would be greatly appreciated. See my config files below.

    Also does anyone have a Tronxy X5ST?

    Home all file:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 20 2019 00:53:57 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-505 Y-505 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-505 ; home X axis
    G1 S1 Y-505 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-505 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y-505 ; then move slowly to Y axis endstop
    G1 S1 Z-605 F1800 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    Home X:
    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 20 2019 00:53:58 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-505 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000 ; go back a few mm
    G1 S1 X-505 F360 ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    Home Y file:

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 20 2019 00:53:58 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 Y-505 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-505 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    Home z file:

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 20 2019 00:53:58 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 Z-605 F1800 ; move Z down until the endstop is triggered
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    Main config file:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 20 2019 00:53:57 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"Revo 1" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Spaghetti" P"donttellne1" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E98.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E1500.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X950.00 Y950.00 Z950.00 E950.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X500 Y500 Z600 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M558 P2 H5 F120 T6000 ; Set Z probe type to modulated and the dive height + speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:500 Y15:500 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured



  • I see you have a Z probe configured but are homing with it.
    I have a Tronxy X5S fitted with dc42's ir probe.
    Here's my homez.g and homeall.g.

    ;homez.g
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Nov 10 2018 14:56:37 GMT+0000 (GMT Standard Time)
    ; Use the probe offset

    G91 ; relative positioning
    G1 S2 Z5 F100 ; lift Z relative to current position
    G90 ; back to absolute positioning
    G1 X160 Y160 F4000 ; Go to centre of bed

    ; Probe
    M558 A1 F350 ; Set single probing at faster feed rate
    G30 ; Do a single probe to home our Z axis
    M558 A10 F100 ; Set triple probing at slower feed rate
    G30 ; Probe again to get a more accurate position and set Z to trigger height

    ;homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Nov 10 2018 14:56:37 GMT+0000 (GMT Standard Time)
    G91 ; relative positioning
    G1 S1 X-325 Y-325 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-325 ; home X axis
    G1 S1 Y-325 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-325 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y-325 ; then move slowly to Y axis endstop
    M98 Phomez.g ; home z using homez.g file

    This works for me.


  • administrators

    @pauljsr said in Tronxy X5ST 500 configure to Duet Wifi 2:

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 20 2019 00:53:58 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 Z-605 F1800 ; move Z down until the endstop is triggered
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    Your homez.g file is set up to use a Z min endstop switch. Does your Z axis have that switch? If so, have you tested that the firmware is reading it correctly? See https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Test_endstop_switches.

    ; Z-Probe
    M558 P2 H5 F120 T6000 ; Set Z probe type to modulated and the dive height + speeds

    Z probe type 2 (P2 in M558) is only used by a few particular printers (Ormerod 2, Huxley Duo), so it isn't right for your printer. If you don't have a Z probe, use P0 in that command. If you do, see https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe and https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.

    HTH David



  • Thank you both! I am new to this and appreciate both of your responses. I took some time to go through them both and learned I do not have a z end stop, but a Z probe. I have the TronXY XY-08N and I read about it where it was mentioned in another post on this forum. I had it plugged into the Z end stop input (sounds like it can't draw enough power there. Can I change the connector and connect to the Z probe input next to the Panel Duel? The Z probe only has 3 wires (black, brown and blue) while the Z probe input has 4 slots. I see where ground goes but unsure where to put the brown and blue wires and one would be left open?

    I saw the post about using the always on fan input to power the sensor. What is a fan voltage jumper and where do I get one of those?

    At this stage I need to get this sensor connected properly. But looking forward to configuration, should I select Unmodulated or smart IR probe, Simple modulated Ir probe, Smart effecto or Piezo or BL touch? Then what should my trigger height and value be?

    Thanks again. Looking forward to getting this thing fired up.



  • If you have the stock tronxy inductive probe its voltage range is between 3V and 36V. I used the 12V power supply from a spare 'always on' fan connector (blue is 0V, brown is +ve) and then connected the remaining black output wire to the Zprobe in pin which is the leftmost pin on the Zprobe input connector next to the paneldue connector.
    If you have dc42's ir probe you connect it directly to the 0v, 3.3v and probe in pins on the probe input connector.
    Your M558 command in config.g should look something like this for the ir probe:
    M558 P1 P500 Z1.0.



  • @pauljsr You may have read my post on the TronXY XY-08N probe setup.

    To have to have the probe work, the wiring diagram is correct. Make sure the blue/brown wires are in the same orientation as the diagram. If you reverse these 2 wires, the probe will not work.
    The fan jumper is already on the Duet board just below the fan plug and should already be jumped for you. It's not a part you need to buy.

    I did not change anyhting in my homex, homey, homez or bed G files.

    Here is the only thing I needed to adjust in my config.g file to make this work:
    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 I1 H1 F100 T36000 ; Set Z probe type to modulated and the dive height + speeds
    G31 P250 X-32 Y-10 Z-0.5 ; Set Z probe trigger value, offset and trigger height
    M557 X10:510 Y10:510 S170 ; Define mesh grid

    I have modified the lines above for your 500mm bed size so if you enter the g-code G29 in your G-Code Console, you will have a 9 point grid.

    So, just comment out all the lines in your current config.g file in the Z-Probe section (keep them, but comment them). To comment them, add a ; in front of each line.

    Add the exact lines I have provided above and power cycle your Duet board. It should work for you.

    Good luck.



  • Thank you @DennisHall and @chas2706 I got the Z prove to light up and seems to be connected properly! Unfortunately my dynamic test is failed. When I put a flat surface under the probe it lit up but the z axis did not stop moving. I used the Z probe config codes you sent. Any ideas what could be going wrong here? Thanks again.



  • Paul, your homez.g should look something like this:
    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Nov 10 2018 14:56:37 GMT+0000 (GMT Standard Time)
    ; Use the probe offset

    G91 ; relative positioning
    G1 S2 Z5 F100 ; lift Z relative to current position
    G90 ; back to absolute positioning
    G1 X160 Y160 F4000 ; Go to centre of bed

    ; Probe
    M558 A1 F350 ; Set single probing at faster feed rate
    G30 ; Do a single probe to home our Z axis
    M558 A10 F100 ; Set triple probing at slower feed rate
    G30 ; Probe again to get a more accurate position and set Z to trigger height

    The G30 command above is using the probe to home Z. You need to adjust your homeall.g as well by replacing the section where Z is homed with the above gcode.



  • @pauljsr In my gocde above, the : M558 P5 I1 H1 F100 T36000 line is the controlling line for the Z-Probe.

    With this setting and when the red light on (i.e. holding metal under the probe), open your GCode console and enter M119
    It should read Z Endstop TRIGGERED when your red light is on.
    If it does not read TRIGGER for your Z Endstop when that light is red, then your probe is either scrap or you have your brown and blue wires reversed.

    It is (knowing TronXY) possible the brown, blue and black wires are not integrated in their problem correctly as well.
    Do not be affraid to connect the wires to the FAN0 points and the far left Z-Probe point beside the LCD 4 wire connector. You will not blow up the Z-Probe, but BE SURE to have the Duet powered off when making wire changes around.



  • Paul, I had the same inductive sensor fitted on my tronxy X5S but now replaced it with dc42's ir probe.
    To get your tronxy probe to work you need your M558 command in config.g as dennis pointed out above and your homez.g and homeall.g set up to home with a probe.
    You also need to connect the probe as follows:
    blue wire connected to 0V
    brown to 12V - I used a spare always on fan connector.
    black wire connects to the probe input connector which is the leftmost pin next to the 4 pin paneldue connector.
    after this all should be good.



  • Thanks again @chas2706 and @DennisHall
    I got that all configured and got some printing going but the filament keeps getting jammed. The extruder spins but filament gets stuck after a few layers. Other than cleaning out the nozzle, how can I prevent this? Lower temperature or turn fans up? Best, Paul



  • @pauljsr said in Tronxy X5ST 500 configure to Duet Wifi 2:

    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1

    These are very likely wrong for your printer.
    From a config i found for marlin
    Bed: 1 : 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
    Hotend: 11 : 100k beta 3950 1% thermistor (4.7k pullup)

    The problem with 11 is they vary by a wide margin.
    so you are prob printing at the wrong temperature.
    see this thread about a discussion for calculation of the correct values: https://forum.duet3d.com/topic/9464/m305-thermistor-values-for-the-duet-maestro-on-the-ender-3-pro/2



  • @PaulJSR
    I take it that your printer has the original Bowden set up and from your first post I am guessing that you have never had it running.
    Where I am coming from is that I have a Tronxy X5S that had a Bowden set up and I couldn't for the life of me get the dammed extruder working long enough to do a print without clogging up. I blamed it on the ridiculously long length of Bowden tube that is required.
    I converted mine to direct drive and have never looked back.



  • @pauljsr I agree with @Veti .
    Sounds like your tempurature is too high or to low for the type of filament you're using.
    I also understand the response from @chas2706 , but in your case, it seems pretty consistent "gets stuck after a few layers" which tells me there is a cool-down happening in your hotend. A few layers, based on a similar print size, would have this effect.



  • Thank you @chas2706 @DennisHall @Veti I apologize for the delay I have been out of town. I just ordered new tubes since I can't even unclog the the one that I have. I am told this is called heat creep and assume this is due to my temperature and fan settings being wrong. I will try to adjust the config and if that doesn't work possibly get a direct extruder. Any hot end and fan config suggestions are appreciated. Thanks!



  • @PaulJSR My X5S came fitted with the same extruder as your X5ST. If you look closely at the nozzle cooling fan you can see that it is a bad design because the fan also blows onto the hotend!

    If you decide to go with a direct extruder I have this:

    https://www.amazon.co.uk/gp/product/B07C24V3FL/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1

    It is a chinese clone but works well as long as you throw away the stepper motor that comes with it because it is way under-powered for the job. The design is extremely light for a direct extruder set up and less than a quarter of the price of the genuine equivalent.

    You would also need to print an extruder mount and fan parts from thingiverse:
    Extruder mount:
    https://www.thingiverse.com/thing:2871308
    The cooling fan parts are contained in a link in the above mount.

    P.S the titan clone can be used as both a direct extruder system or a bowden one. Everything is supplied for both configs.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.