Fan Control issue



  • I was changing my filament over so I selected the tool on my Panel Due, set temp to 205.
    As expected the hot end fan went full power as I thought I had programmed it too, Fan % on Panel Due indicated 100%, brill
    Changed filament and started a print.
    The Fan dropped its speed and the Panel Due reported 0%, but it was still spinning but slowly.
    P0 is Hot end fan
    P1 is Part fan (Changed Cura to turn this fan on after 1st layer)
    P2 is case fan - thermo controlled.
    I checked my Start G-code in Cura and there is no M106 commands
    I have also looked at the Gcode file that I am printing and there is only 2 M106's, 1 to start the fan and 1 stop stop at the end of the print.

    Below is the relevant lines from my config.g if someone can tell me where I went wrong please !
    ; Fans
    M106 P0 S1 I0 F500 H1 T40 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    Thank you.



  • @paulhew Well normally P0 is the part cooling fan and P1 is the hot end fan. So the very simplest thing to do is swap those lines in config.g and physically swap the fans where they plug into the board.

    Edit. A bit more complicated but if you really want to use fan 0 as the part cooling fan, then you can map it to a tool using M563.

    2nd Edit. To be clear in my first sentence, use M106 P0 S0 I0 F500 H-1 for the part cooling fan and M106 P1 S1 I0 F500 H1 T40 for the hot end fan.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.