Kossel Build Not Homing



  • I am setting up a Kossel with duet wifi and smart effector with Hayden's rods and am having issue with the home function not working. When I hit home it moves the carriage down about 10-15mm. I'm fairly new to reprap so any help would be greatly appreciated.

    My config.g
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 25 2019 18:10:38 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M665 R134 L288.16 B115 H300 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 P"Duet Kossel" ; Set machine name
    M552 S1 ; Enable network
    M587 ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E93.00 ; Set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 S1 Z-0.1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    ; M558 P5 R0.4 F1000 T6000 ; Set Z probe type to effector and the dive height + speeds M558 P1 R0.4 H5 F1200 T6000 X0 Z0
    ; M558 H30 ;*** Remove this line after delta calibration has been done and new delta parameters have been saved
    ; G31 P100 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    ; M557 R115 S20 ; Define mesh grid

    M574 X2 Y2 Z2 S0 ; Define active low and unused microswitches
    M558 P5 R0.4 F1000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P100 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    M557 R110 S30 ; define a grid with the specified radius and spacing (for delta printers)

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 R4700 ; Set thermistor + ADC parameters for heater 1 ;M305 P1 T100000 B4267 R4700 H30 L0 ;
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    Bed.g
    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 25 2019 18:10:38 GMT-0500 (Central Daylight Time)
    M561 ; clear any bed transform
    ; Probe the bed at 3 peripheral and 0 halfway points, and perform 3-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y84.9 H0 Z-99999
    G30 P1 X73.53 Y-42.45 H0 Z-99999
    G30 P2 X-73.53 Y-42.45 H0 Z-99999
    G30 P3 X0 Y0 H0 Z-99999 S3
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)

    Homedelta.g
    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 25 2019 18:10:38 GMT-0500 (Central Daylight Time)
    G91 ; relative positioning

    G1 S1 X300 Y300 Z300 F1800 ; move all towers to the high end stopping at the endstops (first pass)
    G1 S2 X-5 Y-5 Z-5 ; go down a few mm
    G1 S1 X10 Y10 Z10 F360 ; move all towers up once more (second pass)
    G1 Z-5 F6000 ; move down a few mm so that the nozzle can be centred
    G90 ; absolute positioning
    G1 X0 Y0 F2000 ; move X+Y to the centre



  • I would suggest checking the end stop status with M119 first to make sure they don't need inverting.
    If they do, swap M574.

    If not, your motors are going the wrong way



  • Also in your Homedelta.g file change

    G1 S1 X300 Y300 Z300 F1800 ; move all towers to the high end stopping at the endstops (first pass)

    to

    G1 S1 X600 Y600 Z600 F1800 ; move all towers to the high end stopping at the endstops (first pass)

    this is to ensure that it will home in one pass rather than 2 (ie if the nozzle is not centred on the bed then homing to the Z Hight won't actually reach).

    Then follow what Jay_s_uk has said for initial testing

    Doug



  • Thank you all. Seeing as I used the original stepper motor plugs I do believe they are backwards. I'm at work now and will report back later this afternoon.

    Thank you for the tip on the homedelta file as well.



  • you may well have used the original motor plugs but that doesn't mean that the config hasn't got them reversed.

    If they are then simply change the S1 on your M569 lines to S0.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.