NPN Probe and Error: M280: Invalid servo index 3 in M280 command

  • Hi All,
    I have a Duet WIFI connected to my Hypercube Evo and X and Y home perfectly.
    I am using a NPN induction probe with the brown wire connected to VIN and the blue wire to ground next to it, I have a BAT43 diode connected to the output from the probe and that is connected to Z Probe IN as per the diagram in the connecting a Z probe guide. It triggers when the bed comes up & the probe value shows as 1000.

    The problem is when I try to home Z I am getting this Error: M280: Invalid servo index 3 in M280 command.

    Here are settings in the config.g
    ; Z-Probe
    M574 Z1 S2
    M558 P5 H5 I1 F120 T6000
    G31 P500 X0 Y0 Z2.5
    M557 X15:485 Y15:485 S20

    If someone can shed some light on this for me it would be great.
    I did try searching myself but all the info I could find seemed to be related to BLtouch probes.


  • It is a Core XY with a Duet 2 WIFI and the latest version of the firmware

  • Check if you have deployprobe.g and retractprobe.g in your /sys folder, if that is the case, remove them 🙂

  • @whosrdaddy Awesome that worked a treat thanks!

  • Great!

    Now you can mark this thread as solved 😉

Log in to reply