Capacitive npn sensor



  • Hi. I have fitted a NPN capacitive sensor to the duet wifi. I have powered it 12v from psu and signalled from z min. it works fine on homing but when I go G29 it either says insufficient points probed or error probe already triggered. If I home and then run a M119 it shows Error: Z probe already triggered before probing move started.
    I'm probably an idiot and it's something simple. I have set the probe to mode 7 for the z input.





  • @bravo6 Raise the Z enough for it not to be triggered? On my printer, it needs to start at least 5mm above the bed to be not triggered.



  • Maybe i'm readign this wrong, but you're saying you're using mode 7, which is the z-endstop as input for the npn sensor, G29 doesn't work.

    You need to run G28/home before G29, and that would rely on the z-endstop, leaving the sensor triggered. So maybe Stephen is right, try raising your Z axis and look at web interface Settings -> Machine configuration -> Endstop hit and keep raising Z until it changes to no, and try again.

    If that helps, just add G0 Z5 (or whatever value instead of 5 that your switch no longer triggers) to bottom of homeall.g. Another suggestion is to increase your dive height in the M558 command to see if it will raise Z despite being triggered before probing.



  • Thanks all for the responces. Will try dropping the bed out of range but the led is off on the sensor. I did g28 then g29 from past marlin experiences..



  • What is in you homeall.g?



  • @phaedrux ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun May 12 2019 19:03:49 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 Z5 F800 S2 ; lift Z relative to current position
    G1 S1 X-265 Y-265 F800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F900 ; go back a few mm
    G1 S1 X-265 Y-265 F800 ; move slowly to X and Y axis endstops once more (second pass)
    G1 S1 Z-355 F800 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 S2 Z5 F100 ; lift Z relative to current position
    G90 ; absolute positioning



  • @phaedrux Just trying new settings with mode 5 selected and M558 i1



  • @bravo6 yep will do thanks


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.