X and Y shift during printing.



  • I started a print off before I went out, have done about 3 or 4 prints this morning already.
    Came back and found this.

    0_1557742260537_IMG_20190513_110646.jpg
    0_1557742272788_IMG_20190513_110624.jpg

    Have checked the temp of my X and Y steppers and they are warm only and no one was here whilst it was printing.
    Recently had this happen a couple of times now.
    These are the original steppers supplied with the Ender 3 Pro.

    Any advice would be appreciaed.
    KR Paul.



  • post your config.

    if you have not changed anything then check for a mechanical issue.



  • Thanks @Veti

    Nothing to get tangled on either axis.

    Config.g as requested.0_1557742919267_config(1).g

    E3D Titan extruder and recommended motor
    XYZ axis using original Ender 3 Pro motors.



  • only thing i can see is that you are running your steppers at 100%
    https://gist.github.com/knoopx/e6c40a009e796203b93a75a3ed6a5ab8

    Normal should be around 75% if the current of the steppers.
    see https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Rated_current

    try with 700mA for X,Y,Z



  • What about the nozzle having hit a printed part causing your X/Y steppers to loose some steps?



  • Thanks @Veti again!
    I will change and try those values.

    @themelle - Good call but nothing has been 'knocked' ie none of the printed parts have shifted. Will keep an eye on it though.



  • if it persist try disabling stealthchop2 using
    M569 P0 D2
    M569 P1 D2



  • It did it again, I had already started printing when I received the setting suggestions.
    Rebooted rig.
    Set slicer to NOT use firmware retraction.
    Load Phaedrux's Ender Profile, dropped speed to 50mm and trying again....

    Another thing I have noticed, when printing I can hear my tool fan as I have programmed it using code in my config.g. which is fine, as that is what I want, the fan running full chat after the hotend goes above a certain temp.
    I have noticed a couple of times on subsequent prints that the fan does not run as fast, but if I reboot the rig when the hotend is hot the fan kicks back in at full speed.
    Even moving the tool fan slider in DWC does not reset the speed to full speed, only a reboot will cure it.

    I have checked my slicer and gcode and the only reference it has is to Fan0 the part fan.


  • administrators

    Which firmware version are you using? If it's below 2.02 stable release then please upgrade it. Some older firmware versions left the drivers run in stealthChop mode by default even at high speeds, and skipped steps are much more likely when using stealthChop.



  • also there was a bug with the time keeping constant on longer prints below 2.02 which would cause layer shifts after the printer being on for a long time.



  • Current fimware as requested
    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.02RC3(RTOS) (2018-10-17b2)
    Web Interface Version: 1.22.6

    Thanks DC and Veti


  • administrators

    @paulhew said in X and Y shift during printing.:

    Current fimware as requested
    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.02RC3(RTOS) (2018-10-17b2)
    Web Interface Version: 1.22.6

    Please upgrade to 2.02 stable release or to 2.03RC1, both available via https://github.com/dc42/RepRapFirmware/releases.



  • Stopped the print, now running
    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.03RC1 (2019-05-08b1)
    Web Interface Version: 1.22.6

    Thanks again all.


  • administrators

    @paulhew said in X and Y shift during printing.:

    Stopped the print, now running
    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.03RC1 (2019-05-08b1)
    Web Interface Version: 1.22.6

    Thanks again all.

    Let us know if it fixes the problem. I can't remember whether the change to the stealthChop settings was made before or after 2.03RC3.



  • Ignore the fan issue, it was a ID10T error.
    I left something in the End gcode section.....Sorry



  • Fan issue is not a ID10T problem.
    I have just printed something again and the tool fan was running slow again.
    Checked the GCode file for M106's and it only references the Part fan as far as I can see.
    [0_1557774592616_CE3_Mk6_-CR-10-GT2-X_Tensioner-_Body.gcode
    This is the file if someone would be good enough to have a look to make sure I am not going mad!


  • administrators

    @paulhew, Part Fan == Tool Fan. It's the fan used to cool the print, mounted on the tool. The hot end heatsink fan is different.



  • My Bad, I thought the tool fan referend to the hotend fan
    Hotend fan is having this issue. It is controlled by the duet gcode.

    This morning I have been testing the hotend and every time it runs at full speed, after a heating and cooling cycle.

    Code responsible
    M106 P1 S1 I0 F500 H1 T40
    Do I need the F parameter? I only need it on or off. I know its default is 250 if it is omitted.



  • @paulhew said in X and Y shift during printing.:

    M106 P1 S1 I0 F500 H1 T40

    if that line is in your config.g then the fan will turn when the hotend reaches 40 degrees and turn off when below. there is no need to control it via the g code.



  • @veti said in X and Y shift during printing.:

    Normal should be around 75% if the current of the steppers.
    see https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Rated_current

    Isn't that just to keep the temp of the steppers down to avoid printed mounts going soft? Don't think the Ender 3 uses printed parts on the motor mounts.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.