24v kills PanelDue

  • Hello,

    Recently I purchased DuetMaestro and PanelDue 5i. After initial setup using USB cable and ethernet everything worked fine. When I connected main power supply 24V initially everything booted but then screen started showing error (something about checking G code) and screen was unresponsive. So I rebooted everything and since then screen is white and not working.

    So I followed advice on forum and flashed latest firmware for DuetMaestro as well as new firmware for PanelDue, unfortunately it did't help.

    DuetMaestro Is still working fine, I can control axis through web interface, however when I try homing any of the axis I'm getting error saying "G-Code is missing". I assume that after firmware update I have to preload new G-codes am I right?

    So after all this I requested replacement of PanelDue from Ooznest which arrived today.
    I carefully reconnected everything again, LCD worked fine from USB power supply and then when I applied 24v again PanelDue died :(:(

    I doubt that they will replace my panel again.

  • I have most of it figured out ! Looks like it was common mistake my case being to tight for the LCD, Loosened some screws and now screen finally works ! Now I only have to figure out how to load homing G-codes. I have to say its not as plug and play as I thought it would be but I'm getting there, I hope its worth all the effort .

  • Moderator

    You should probably generate a configuration file set using the online configurator tool first.


    The documentation is a big help as well.


  • The case being too tight can damage the screen. I had a brand new 5i, where the screen cover glass cracked in one corner (I only found it with careful inspection) - that crack made the touch chip unable to find out where I tapped (made the display useless, and I had to replace the touch panel).

  • I downloaded and printed a 5inch paneldue case from thingiverse that caused my display to show random windows to pop up and disappear.
    It took me ages to realise it was the case applying pressure onto the touch screen.
    As @Arkadiusz says, loosening the screws rectified the problem.

Log in to reply