MinebaMitsumi 17PM-KA39B steppers not moving (Atom 2.0 upgrade)



  • Hi all,

    I'm in the process of converting an Atom 2.0 delta 3D printer to using Duet and am stuck at the stepper motors. The motors are MinebaMitsumi 17PM-KA39B with the following specs:

    0_1558097142165_d898b5e7-c325-46f3-8e68-038c7e5d11ea-image.png

    I've followed the instructions, but that did not work out because the motors were not homed (even with the M564 S0 H0 sequence).

    Instead, I've tried the following:

    G91 ; relative mode
    G1 S2 X1 ; move the X carriage up 1mm
    

    and I do hear a sound coming from the motor, but there is no movement whatsoever. Is there some specific configuration that I need to do? The wiring seems good as well:

    0_1558097457504_75e4c79d-3ae5-44c8-85df-ba20ee5c7eeb-image.png

    0_1558097496817_a72a7be5-2c8f-425b-9678-30019ed2f52f-image.png

    Any advice would be much appreciated!


  • administrators

    Please post your config.g file. In particular, what motor currents have you set in the M906 command?



  • @sebastien Have you used a multimeter to verify the motors are wired correctly?



  • @dc42 Thanks for the quick reply! Here is the M906 output

    Motor current (mA) - X:1000, Y:1000, Z:1000, E:800:800, idle factor 30%
    

    This is probably the problem -- I have no idea which values I should enter. I tried your spreadsheet but did not see where I could input the values in the RepRap FW configurator. As you've probably guessed I'm quite new to such a level of configuration.

    @Stephen6309 not yet, my multimeter ran out of batteries but the motors were working fine with the stock Atom board, so I assume they're wired properly on the motor end.

    Here's the config.g, as generated by the RepRap FW configurator:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri May 17 2019 08:06:27 GMT-0400 (Eastern Daylight Time)
    
    ; General preferences
    G90                                         ; Send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M665 R105.6 L215 B85 H250                   ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0                               ; Put your endstop adjustments here, or let auto calibration find them
    
    ; Network
    M550 P"XXX"                                 ; Set machine name
    M551 P"XXX"                                 ; Set password
    M552 S1                                     ; Enable network
    M587 S"XXX" P"XXX"                          ; Configure access point. You can delete this line once connected
    M586 P0 S1                                  ; Enable HTTP
    M586 P1 S0                                  ; Disable FTP
    M586 P2 S0                                  ; Disable Telnet
    
    ; Drives
    M569 P0 S1                                  ; Physical drive 0 goes forwards
    M569 P1 S1                                  ; Physical drive 1 goes forwards
    M569 P2 S1                                  ; Physical drive 2 goes forwards
    M569 P3 S0                                  ; Physical drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1                     ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E663.00            ; Set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00    ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00    ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                  ; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1                            ; Set active high endstops
    
    ; Z-Probe
    M558 P4 H5 F120 T6000                       ; Set Z probe type to switch and the dive height + speeds
    M558 H30                                    ;*** Remove this line after delta calibration has been done and new delta parameters have been saved
    G31 P500 X0 Y0 Z2.5                         ; Set Z probe trigger value, offset and trigger height
    M557 R85 S20                                ; Define mesh grid
    
    ; Heaters
    M140 H-1                                    ; Disable heated bed
    M305 P1 T100000 B4138 R4700                 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                                ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0 I0 F500 H T45                    ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45                   ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                               ; Define tool 0
    G10 P0 X0 Y0 Z0                             ; Set tool 0 axis offsets
    G10 P0 R0 S0                                ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    


  • Replying to myself here, but basically the wiring was OK and that I thought there was a problem because the movement was too brief. I was using G1 S2 X1, but using a higher value such as G1 S2 X10 makes the movement more visible.

    The main thing that made me think there was an issue is that the motor produce a sound after a G1 S2 command even when they're not moving, while I thought they would power off after the movement is complete. Issuing a M1 command does stop the noise from the motors.


  • administrators

    @sebastien said in MinebaMitsumi 17PM-KA39B steppers not moving (Atom 2.0 upgrade):

    Replying to myself here, but basically the wiring was OK and that I thought there was a problem because the movement was too brief. I was using G1 S2 X1, but using a higher value such as G1 S2 X10 makes the movement more visible.

    The main thing that made me think there was an issue is that the motor produce a sound after a G1 S2 command even when they're not moving, while I thought they would power off after the movement is complete. Issuing a M1 command does stop the noise from the motors.

    So it's working after all?

    When you first power up the printer, the motors are not powered. After you first move a motor, it remains powered at the end of the movement, in order to hold position. The motor current will be reduced to the idle value (default 30% current) after all motors have been idle for the idle time (default 30 seconds). The firmware assumes that the motors will still hold position at the idle current setting. On some printers (mostly deltas), you need to increase the idle current percentage to make sure of this.

    You can disable the motors (i.e. reduce current to zero until they are commanded to move again) using M18 or M84, but then they are not guaranteed to hold position, so the associated axes will be flagged as not having been homed.

    HTH David


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.