bltouch and how to auto level bed?



  • hello guys so i just put my duet 2 wifi on my tevo tornado with some help from a really cool guy of the tornado facebook group but im not sure how to get the auto bed leveling to work its the last thing i have to do before i can print any help would be great here is my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Apr 03 2019 15:50:04 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"PrinterOfThings" ; Set machine name
    M552 S1
    M552 P10.0.20.25
    M554 P10.0.1.0
    M553 P255.255.0.0 ; Enable network
    M586 P0 S1 ; Enable HTTP
    ;M586 P1 S1 ; Enable FTP
    ;M586 P2 S1 ; Enable Telnet

    ; Drives
    M569 P0 S0 ; Drive X goes Backwards
    M569 P1 S0 ; Drive Y goes Backwards
    M569 P2 S1 ; Drive Z goes Forwards
    M569 P3 S0 ; Drive E goes Backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E412.6 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z6000.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X200.00 Y200.00 Z100.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X900.00 Y900.00 Z900.00 E900.00 I10 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z-20 S1 ; Set axis minima
    M208 X300 Y300 Z400 S0 ; Set axis maxima
    M591 D0 P1 C3 S1 ;sets filament out sensor Extruder 0 P2 switch type high = out c 3 extruder limit 0
    ;M591 D1 P1 C4 ;sets filament out sensor Extruder 1 P2 switch type high = out c 3 extruder limit 0
    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops
    M574 Z1 S2 ; Define Z to use Probe. Home to Min

    ; Z-Probe
    ; BLTouch - Heaters
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.
    M557 X15:285 Y15:285 S50 ; Define mesh grid
    M558 P9 H5 F100 T6000 A5 R0.2 ; P9 for BLTouch, dive height 5mm, probe at 100mm/min, travel 6000mm/min, up to 5 probes, pause 0.1s
    G31 X-45 Y-5 Z0.350 P25 ; probe XY offset and Z trigger height and trigger value
    M557 X5:300 Y5:300 S50 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S265 ; Set temperature limit for heater 1 to 265C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory



  • In the web page for your duet board, DWC, click the Auto Bed Compensation

    0_1558126523444_d3733dfd-ac02-449a-8f59-55dea6c05e0e-image.png and if you click the button it will probe the bed.
    From the dropdown you can configure the grid.
    Make sure in your slicer you include 'G29 S1 ; Get mesh' in your start GCode.

    HTH
    Paul



  • ok thank you so now im having a problem with my bltouch it seems to stutter when i probe the bed as if there is a voltage drop on the magnet in it or something so it gives me an error Error: Z probe readings not consistent


Log in to reply