Flying Extruders On Custom Delta

  • Hi everyone,

    I built a custom Delta style printer a couple of months ago, with a Duet Wifi controller and Duet Smart Effector. Initially, I had the extruders mounted stationary and everything was working perfectly, but recently added a Duex 5 expansion board to facilitate an additional motor for a flying extruder (I have two extruders, so all drivers were spoken for on the main board).

    I'm just having a little trouble getting the flying extruder U-axis to work properly. I can get it to home with the X, Y, and Z axes, for the most part. However, it doesn't seem to want to move down after the second homing move. All four axes move up to their home switches, move down a little, move up to their switches again, but then the U axis does not come down with the rest. Additionally, after homing, the U axis does not move with the hot end at all.

    Could someone possible check out my config and homedelta files, and maybe see what I'm missing?

    I am expecting to have 210mm of bowden tube between the extruders and hot end, so I set the fourth rod length in M665 to that number. Also, you'll notice that in homedelta that I added a U-20 to the final move, which was the only way I could get it to follow the others after the second homing move.

    After homing, the axes show as X= 0, Y-0, Z=532.92, and U=180 (which seems odd since I set the U 'rod length' to 210, and told it to move down 20 at the end of homedelta, so it seems like it should be 190)...perhaps this is related to the problem? If I don't put the U-20 parameter at the last move, the U value stays at 200...which again it seems like it should be 210, or maybe something like the Z height plus 210??

    I'd appreciate any input! Thanks!
    0_1558126076621_config (1).g

  • I was able to solve this issue by upgrading to a 2.03 firmware release. While reading another thread here on flying extruders from earlier this year, I failed to realize that the supporting firmware was much newer than I though. So, all is well!

Log in to reply