Sensorless Homing Not Working Anymore



  • I have configured my printer to use sensorless homing. I was experience some issues where sometimes one of the towers might not actually move the motor - as if it had detected something without even moving. I was trying some tweaking and now the belt just vibrates when it hits the hard plastic stopping block. Note that I have verified the motor isn't spinning anymore, it is just the belt is vibrating. So I haven't been able to figure out what is actually going on and why it isn't detecting the stop.

    Unfortunately, I didn't end up keeping my original config, but it seems to be the same so far as I remember.

    Some notable points from my config:

    M574 X2 Y2 Z2 S3             
    M915 X Y Z F0 S3 H200 R0
    

    and from my home delta:

    G91                       ; relative positioning
    
    M400 
    
    M913 X25 Y25 Z25
    G1 H1 X300 Y300 Z300 F1800 ; move all towers to the high end stopping at the endstops (first pass)
    G1 X-5 Y-5 Z-5 F1800 H2   ; go down a few mm
    G1 H1 X10 Y10 Z10 F360    ; move all towers up once more (second pass)
    G1 Z-5 F6000              ; move down a few mm so that the nozzle can be centered
    G90                       ; absolute positioning
    G1 X0 Y0 F6000            ; move X+Y to the center
    
    M913 X100 Y100 Z100
    

    I have tried various amounts of current %, filtered and not, sensitivities (even down to -10), etc.

    Any suggestions would be helpful.



  • @zzing I remember to have had some issues when speed was too low.
    In my settings I have F2000. For the rest, the settings seem OK to me if the 25% current allows you to move the drivers (my minimum was 35% and below that it would fail).


  • administrators

    As @carlosspr says. For stall detection to work, the feed rate in your G1 S1 commands must be at least (60 * m915-h-value / full-steps-per-mm) . If your printer has 80 steps/mm @ x16 microstepping, that's 5 full steps/mm. You are using H200 in M915, so the minimum G1 S1 feed rate would be (200 * 60)/5 = 2400.



  • This post is deleted!

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.