Y Axis Zero at wrong end



  • Dear all

    I have troubles to setup my Duet3D WiFi correctly.
    I'm on Firmware 2.02(RTOS) (2018-12-24b1)

    The problem is, that the Y Axis is moving in the wrong direction.
    When looking towards the printer, then Y0 is away from me. Therefore a G1 Y200 shifts the bed away from me.

    Y Endstop is at the Y+ side
    Y Motor is at the Y+ side

    Also all printed parts are mirrored in the Y direction.

    I've played already around with reversing the motor wiring and with the M586 and with the homeall.g file as well but none of them (or combination worked).
    X-Axis and Z-Axis are working normal.

    Have spend already many hours to figure out what's wrong but without look. Therefore reaching out to you for help.

    I've made a drawing for better clarification and also attached my configuration files and homing files.

    0_1558741766910_Printer Setup.jpg
    1_1558741873260_config.g
    0_1558741873260_homeall.g



  • In the picture you posted, if the bed is moving in toward you, then isn't the nozzle moving in +Y direction relative to the bed/part, correct? Assuming since the bed moves then the nozzle is not moving in Y direction. A G1 Y200 should move the bed towards you on most standard bed-moving printers (prusa i3 style, etc).

    If this is the case then you need to change your motor direction (M569), endstop direction, and homing macro files.

    But I could be looking at the picture wrong.



  • Dear @nhof

    Many thanks for your quick reply. I'm sorry to post my answer not sooner due to lot of work and also illnes unfortunately.
    I owe you something. You saved me hours of try and error. You were exactly right.

    But I could be looking at the picture wrong.

    May i ask you, What was unclear about the picture?

    In the picture you posted, if the bed is moving in toward you, then isn't the nozzle moving in +Y direction relative to the bed/part, correct?

    Thats correct

    If this is the case then you need to change your motor direction (M569), endstop direction, and homing macro files.

    That solved my Problem. Thank you so much!

    A general question:
    In the duet wiki M574 --> Set endstop configuration
    The parameter S is described as: "Snnn Endstop type: 0 = active low endstop input, 1 = active high endstop input, 2 = Z probe, 3 = motor load detection".

    Therefore I'm confused. What exactly is the S parameter?
    Is it the the position at which side the endstop is positioned. At the low or at the high side of the Axis?
    Or is it rather a direction?

    I've uploaded also a picture of the current setup with the endstop marked with purple arrows and the corresponding parameter below.
    This combination worked.!

    My config.g file looks as follows now (working version):

    M569 P0 S0                                 ; X Achse 	 / S0 = Rückwärts S1 = Vorwärts
    M569 P1 S0                                 ; Y Achse 	 / S0 = Rückwärts S1 = Vorwärts
    M569 P2 S1                                 ; Z Achse 	 / S0 = Rückwärts S1 = Vorwärts
    M569 P3 S1                                 ; Extruder E0 / S0 = Rückwärts S1 = Vorwärts
    
    M574 X1 Y1 S1   			   ; End Stop // 0 = Kein, 1 = Low-End, 2 = High-End
    M574 Z1 S2      			   ; BL-Touch
    

    0_1560067868547_IMG_20190609_093914.jpeg



  • @miracuruzrh said in Y Axis Zero at wrong end:

    Therefore I'm confused. What exactly is the S parameter?
    Is it the the position at which side the endstop is positioned. At the low or at the high side of the Axis?

    The S parameter defines the switch type, as in Normally Open, Normally Closed, etc.

    The position of the endstop is defined by the number after the Axis letter. So X1 means the X endstop is at the low end of travel. Y2 means the Y axis endstop is at the high end of travel.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.