BL-Touch and the Duex 5



  • I try something around.. and testing if Heater 3 & PWM1 is better..
    But I get this Message if I start the Alarm Release + Pin Up-Macro

    "
    × G28 Z

    Error: Z probe already triggered at start of probing move
    Error: G0/G1: insufficient axes homed"

    This is the corosponding Config. The macros & other G-Code-Files are similar changed.

    CONFIG.G

    M584 X2 Y1 Z2:6:7 U6 V7 P8 S1 ; three Z motors connected to driver outputs 2, 6 and 7, driver 8 for E1
    M667 S1 ; Select CoreXY mode

    ; Define the X and Y coordinates of the leadscrews.
    ; Must come after M584 (Set drive mapping), M667 (Select CoreXY Mode) and M669 (Choosing Kinematics type)
    ; Motor order: Front right (1), front left (2), rear center (3).
    ; Snn Maximum correction in mm to apply to each leadscrew (optional, default 1.0)
    ;
    M671 X0:320:162 Y0:0:320 S3

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards Z1 (Z)
    M569 P1 S0 ; Drive 1 goes backwards Y
    M569 P2 S0 ; Drive 2 goes backwards X
    M569 P3 S0 ; Drive 3 goes backwards E2 (E1)
    M569 P4 S0 ; Drive 4 goes backwards E3 (E2)
    M569 P6 S0 ; Drive 6 goes backwards Z2
    M569 P7 S0 ; Drive 7 goes backwards Z3
    M569 P8 S0 ; Drive 8 goes backwards E1

    M350 X16 Y16 Z16:16:16 U16 V16 E16:16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z800:800:800 U800 V800 E93:93:93 ; Set steps per mm
    M566 X900 Y900 Z12:12:12 U12 V12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z800:800:800 U800 V800 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z300:300:300 U300 V300 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X950 Y950 Z1800:1800:1800 U1800 V1800 E950:950:950 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X324 Y324 Z355 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; Set X=low end Y= high end active high endstops

    ; Z-Probe
    M574 Z1 S1 ; Define Z to use Probe. Home to Min.
    ;M574 Z1 U1 V1 S2 ; Define Z,U,V to use Probe. Home to Min. <-- möglich?
    M558 P9 H3 F500 T9000 X0 Y0 Z1:U1:V1 B1 ; Set Z probe type 9 to bltouch and the drive (5) height + speeds
    ;G31 P25 X+33 Y0 Z0.894 ; Set Z probe trigger value (1-25, not 500), offset and trigger height (3fach-PH noMixing)
    G31 P25 X+26.4 Y15.8 Z0.894 ; Set Z probe trigger value (1-25, not 500), offset and trigger height (Diamond-org)
    M557 X45:325 Y25:325 S30 ; Define mesh grid

    ; BLTouch - Heater 3
    M307 H3 A-1 C-1 D-1 ; Disable heater 3 to free up PWM channel 1 on the Duex board.

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0 (Bed)
    M143 H0 S125 ; Set temperature limit for heater 0 to 125C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1 (Nozzle)
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C
    M140 S35 ; set Bed-Temp to 35C at Starttime

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 22 2019 12:45:27 GMT+0100 (Mitteleuropäische Normalzeit)
    M280 P3 S10

    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 22 2019 12:45:27 GMT+0100 (Mitteleuropäische Normalzeit)
    M280 P3 S90

    Macro:

    Alarm Release + Pin UP<
    M280 P3 S160 ; Alarm Release and Push-Pin UP

    Pin Down<
    M280 P3 S10 ; Send PWM channel 3 the s10 (angle) command

    Pin Up<
    M280 P3 S90 ; Send PWM channel 3 the S90 (angle) command

    ; bed.g
    ; Called using G32
    ; Called to perform True Autolevel using 3-point probe
    ;
    M561 ; clear any bed transform
    G29 S2; Clear bed height map

    ; Probe 3-point

    M98 Pdeployprobe.g ; deploy mechanical Z probe
    M401 ; Deploy probe - deployprobe.g
    G30 P0 X0 Y0 Z-9999 ; Front Right
    G30 P1 X324 Y0 Z-9999 ; Front Left
    G30 P2 X162 Y324 Z-9999 S3 ; Center Rear
    M402 ; Retract Probe - retractprobe.g

    Same Result as bevore... the BL-Touch do nothing.. no error-message



  • wonder if you have an older probe that is 5v only and you are connecting to a 3.3v set of pins for the probe. I used a resistor in order to reduce the voltage slightly



  • Oh no.. it´s a brand new origin Probe..

    But the Cabeling is from the China-Probe.. and they doenst working..
    Is that a Problem?..
    I will check ist.. and remove the resistor.

    But before I change to a DUEX5, this works with the same new origin probe.



  • I have check it.. without Resistor.. no differences... still no function.. hmm

    What I also see.. if the X or Y a little far from 0-Point and start homing x / Y .. thats a little curous.

    normaly . the Z-Axis have a short movement aroubd 10mm down, before homing X/Y .
    My front left leadscrew (1) is running as long as X or Y is moving to the Homing-Point.
    The Leadscrew (2/3) do what they should.... go 10mm.. and stop at self.

    My question, is it better to switch from the origin Z to another driver (maybe one at the duex)??



  • strange.. I´m wondering..
    I thougt about.. why my BLTouch have no power.. it seems so. (No LED is on)

    I check with my Multimeter and I messure nothing at the duex PWM1 - PWM 5 hmmm..
    I double check the two connectors of the Endstops at the Duet.. E0 & E1... and .. oh wondering.. both has power on.. 3,3V to Ground. !
    Why the Hell this Ports and not at the Duex?

    I thought about the flat-Cable wich connect the Duet with the DUEX.. maybe not OK? Hmm, I think it´s ok, in order to the two Z-drives at driver 6 & 7 are working normal..

    Another Test to the extruders shows.. ohh. something goes really wrong!
    Instead of any extruder.. folloing situation:
    E0 = no reaction..nothing
    E1 = the front left Z (U) is flatering not moving
    E2 = the rear middle Z (V) is flatering not moving

    Hmm.. I thing I have a bigger Problem at my config.g and maybe other files.

    I Thought I´m near at btrue´s wiki for 3 Z-Axis & BLTouch
    https://betrue3d.dk/bltouch-on-duet-wifi-configuratio-and-usage/#configuring

    Additional I check the Btrue´s blog for the BLTouch.. and I see, I have the newest Version of the origin Antclabs BLTouch with the plastic Pin.. and.. 3,3V !!

    So my question: Is it rigth to connect the BLTouch with the PWM- connector completle.. incl. the 5V??
    Or is it better and correct, to use in this case, the 3,3V vom the Z-Probe Connector from the Duet-Board?

    What I also see.. at the WEB-Interface.. is the value of Z-Probe .. allways at 1000.. hmm.



  • Push.. no Idea?



  • What is the PCB revision of the Duet? You can see the version number on the PCB itself. If you have a v1.03 or v1.04 board, you don't have to worry about 3.3v versus 5v.

    The web interface shows 1000 most of the time because the trigger time is very short before the pin retracts, so it's not easy to catch it changing.



  • It´s an rev. v1.04
    Thank you for this... but I´m stucking with:

    1. my 3 Z-Axis & the 3 Extruders..
    2. the BLTouch.. without any function

    I play somthing around with different drivers for teh Z-Axis.. and BL-Touch.. and my last version of Config.g is this.. but don´t wirking right.

    M584 X0 Y1 Z5:6:7 U5 V6 W7 P8 S1 ; three Z motors connected to driver outputs 5, 6 and 7 (U,V,W), driver 8 for E2
    ;M667 S1 ; Select CoreXY mode
    M669 K2 Z3 ; switch to CoreXZ mode and multiply motor movements by 3 for the Z axis

    ; Define the X and Y coordinates of the leadscrews.
    ; Must come after M584 (Set drive mapping), M667 (Select CoreXY Mode) and M669 (Choosing Kinematics type)
    ; Motor order: Front right (1), front left (2), rear center (3).
    ; Snn Maximum correction in mm to apply to each leadscrew (optional, default 1.0)
    ;
    M671 X0:320:162 Y0:0:320 S3

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards X
    M569 P1 S0 ; Drive 1 goes backwards Y
    M569 P3 S0 ; Drive 3 goes backwards E0 (E1)
    M569 P4 S0 ; Drive 4 goes backwards E1 (E2)
    M569 P5 S0 ; Drive 5 goes backwards Z1/U
    M569 P6 S0 ; Drive 6 goes backwards Z2 V
    M569 P7 S0 ; Drive 7 goes backwards Z3 W
    M569 P8 S0 ; Drive 8 goes backwards E2

    M350 X16 Y16 Z16:16:16 U16 V16 W16 E16:16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z800:800:800 U800 V800 W800 E93:93:93 ; Set steps per mm
    M566 X900 Y900 Z12:12:12 U12 V12 w12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z800:800:800 U800 V800 w800 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z300:300:300 U300 V300 W300 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X950 Y950 Z1800:1800:1800 U1800 V1800 W1800 E950:950:950 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 U0 V0 W0 S1 ; Set axis minima
    M208 X324 Y324 Z355 U355 V355 W355 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; Set X=low end Y= high end active high endstops

    ; Z-Probe
    ;M574 Z1 S1 ; Define Z to use Probe. Home to Min.
    M574 Z5 S2 ; Define Z to use Probe. Home to Min. <-- möglich?
    M558 P9 H7 F500 T9000 X0 Y0 Z1:U1:V1:W1 B1 ; Set Z probe type 9 to bltouch and the heater (7) height + speeds
    ;G31 P25 X+33 Y0 Z0.894 ; Set Z probe trigger value (1-25, not 500), offset and trigger height (3fach-PH noMixing)
    G31 P25 X+26.4 Y15.8 Z0.894 ; Set Z probe trigger value (1-25, not 500), offset and trigger height (Diamond-org)
    M557 X45:325 Y25:325 S30 ; Define mesh grid

    ; BLTouch - Heater 3
    M307 H7 A-1 C-1 D-1 ; Disable heater 5 to free up PWM channel 1 on the Duex board.

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0 (Bed)
    M143 H0 S125 ; Set temperature limit for heater 0 to 125C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1 (Nozzle)
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C
    ;M140 S35



  • I don´t know if it´s really right to have U,V And W.. or not...
    Or ist it usefull, to all Z-Axis at the duet (5-7) and no use of the original Z?? I dont know

    Nobody can show me really the connection between Heater and PWM.Channels as a Table..(not Pin-#)

    I´m sorry.. I´m not a programmer.. so it´s possible I dont know.. what anybody knows.. who can write programs for ... 3D printers...
    for the Moment I´m at the end of my Knowledge.. but I want to understand what I do.



  • @justd said in BL-Touch and the Duex 5:

    M669 K2 Z3 ; switch to CoreXZ mode and multiply motor movements by 3 for the Z axis

    Is this a CoreXY or CoreXZ?

    I'm not sure what part you're getting stuck on for connecting the BLTouch.
    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Duet_2_WiFi_Ethernet_with_Duex_2_or_Duex_5_expansion_board

    Have you tested the probe using this? https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • uups.. yes.. this is one of my test and play around..

    It´s an Core XY Printer and I actually delete this line. and use the Line above as CoreXY

    Thats what I mean with.. "1. my 3 Z-Axis & the 3 Extruders.."
    "Another Test to the extruders shows.. ohh. something goes really wrong!
    Instead of any extruder.. following situation If I try to extrude (if the Nozzle is hot enough):
    E0 extrude= no reaction..nothing
    E1 extrude= the front left Z (U) is flatering not moving
    E2 extrude= the rear middle Z (V) is flatering not moving

    Yes I know this two Links.. and I tested it... Thats what I describe.. I can´t test the Deploy or retract, if the BL-Touch doesn´t working correctly.. means .. the normal LED (red in my).. is not lighting.
    Nothing.. so you can do no function test.
    I checkt the Cabeling twice and more.. messure from the connector up to the connector at the BLTouch... it´s ok.
    I messure the Output of the board.. nothing to messure.. = no output.. I describe it above.



  • Additional some information.. maybe.. who knows what one of the problems.

    ; bed.g
    ; Called using G32
    ; Called to perform True Autolevel using 3-point probe
    ;
    M561 ; clear any bed transform
    G29 S2; Clear bed height map
    ; Probe 3-point
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    M401 ; Deploy probe - deployprobe.g
    G30 P0 X0 Y0 Z-9999 ; Front Right
    G30 P1 X324 Y0 Z-9999 ; Front Left
    G30 P2 X162 Y324 Z-9999 S3 ; Center Rear
    M402

    ; deployprobe.g
    ; called to deploy a physical Z probe
    M280 P7 S10

    ; retractprobe.g
    ; called to retract a physical Z probe
    M280 P7 S90

    ; homez.g
    ; called to home the Z axis
    ;betrue3d.dk´s Homing-Z5
    ; Homez.g
    G30 ; Do a single probe to home our Z axis
    G90 ; Make sure we are in absolute mode
    G1 Z10 F8000 ; Rapidly move the Z axis to Z=10

    macros/Alarm Release + Pin UP
    M280 P7 S160 ; Alarm Release and Push-Pin UP

    I´v done sucessfull a update.. so I´m actual at the newest Firmaware since two weeks.
    The Powerin is 24V 360W for Board´s and Nozzle-Heater H1
    Bed (H0) has it´s own Powersupply weith 600W

    How can I check the DUEX-Board.. for correct function or is it enogh, if the Z-drivers working?



  • Please help me out.. any hints for Checks.. or solutions?



  • Sorry, but I'm having a hard time following what the issue is at this point. Can you restate the problem as clearly as possible?



  • The Issue is..

    1. the BLTouch doesn´t work .. nothing.. no light.. no function (check on E3/E5/E7, all the same connected with DUEX5)
    2. the three Extruder don´t work... instead of the Extruder working... Z-Axis (connected over DUEX5)wobble/vibrating .. . one Z-Axis in order of one Extruder... (E0 [Duet-E0]->Z1[Duet-Z] /E1 [Duet-E1]=Z2 [DUEX-Dr6] / E2 [DUEX-Dr8]=z3 [DUEX-Dr7]) to each corresponding Z-Axis.


  • @justd If this is how you have the motors connected...........,

    M569 P0 S0 ; X
    M569 P1 S0 ; Y
    M569 P3 S0 ; E0 (E1)
    M569 P4 S0 ; E1 (E2)
    M569 P5 S0 ; Z1/U
    M569 P6 S0 ; Z2 V
    M569 P7 S0 ; Z3 W
    M569 P8 S0 ; E2

    ....then your mapping should look like this

    M584 X0 Y1 Z5:6:7 U5 V6 W7 E3:4:8



  • Hi Ian, big thank you.... thats the problem with the extruders..!!
    One Problem solved..
    Next the BLTouch.. I will check it later...

    Now I´m checked the BLTouch again and again.. Check wiring.. and setup as Betrue to it.

    If I try to Homing Z, I get this Message.
    "G28 Z

    Error: Z probe already triggered at start of probing move
    Error: G0/G1: insufficient axes homed"

    Sometimes.. for a very short while.. the Value of the Z-Probe at the WEB-interface depends on 875 and switch quickly back to 1000.

    Thats the relevant Config.g and Deploy.g/retract.g

    ; Mapping of Driver for X,Y, Z1-3, E1-3
    M584 X0 Y1 Z5:6:7 U5 V6 W7 E3:4:8 ; three Z motors connected to driver outputs 5, 6 and 7 (U,V,W), driver 8 for E2

    M667 S1 ; Select CoreXY mode

    ; Define the X and Y coordinates of the leadscrews.
    ; Must come after M584 (Set drive mapping), M667 (Select CoreXY Mode) and M669 (Choosing Kinematics type)
    ; Motor order: Front right (1), front left (2), rear center (3).
    ; Snn Maximum correction in mm to apply to each leadscrew (optional, default 1.0)
    ;
    M671 X0:320:162 Y0:0:320 S3

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards X
    M569 P1 S0 ; Drive 1 goes backwards Y
    M569 P3 S0 ; Drive 3 goes backwards E0 (E1)
    M569 P4 S0 ; Drive 4 goes backwards E1 (E2)
    M569 P5 S0 ; Drive 5 goes backwards Z1/U
    M569 P6 S0 ; Drive 6 goes backwards Z2 V
    M569 P7 S0 ; Drive 7 goes backwards Z3 W
    M569 P8 S0 ; Drive 8 goes backwards E2

    M350 X16 Y16 Z16:16:16 U16 V16 W16 E16:16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z800:800:800 U800 V800 W800 E93:93:93 ; Set steps per mm
    M566 X900 Y900 Z12:12:12 U12 V12 w12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z800:800:800 U800 V800 w800 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z300:300:300 U300 V300 W300 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X950 Y950 Z1800:1800:1800 U1800 V1800 W1800 E950:950:950 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 U0 V0 W0 S1 ; Set axis minima
    M208 X324 Y324 Z355 U355 V355 W355 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; Set X=low end Y= high end active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Define Z1 to use Probe at low End. Home to Min. S2 = Z probe
    M558 P5 H7 F500 T9000 X0 Y0 Z1:U1:V1:W1 ; Set Z probe type 9 to bltouch (P5 as Betrue3D) and the heater (7) height + speeds (+ B1)
    ;G31 P25 X+33 Y0 Z0.894 ; Set Z probe trigger value (1-25, not 500), offset and trigger height (3fach-PH noMixing)
    G31 P25 X+26.4 Y15.8 Z0.894 ; Set Z probe trigger value (1-25, not 500), offset and trigger height (Diamond-org)
    M557 X45:325 Y25:325 S30 ; Define mesh grid

    ; BLTouch - Heater 7
    M307 H7 A-1 C-1 D-1 ; Disable heater 7 to free up PWM channel 5 on the Duex board.

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ; in order to use the DUEX-5, the ( I1) parameter is not needed.
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 22 2019 12:45:27 GMT+0100 (Mitteleuropäische Normalzeit)
    M280 P7 S10

    ; retractprobe.g
    ; called to retract a physical Z probe
    ; in order to use the DUEX-5, the ( I1) parameter is not needed.
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 22 2019 12:45:27 GMT+0100 (Mitteleuropäische Normalzeit)
    M280 P7 S90



  • Is there any Jumper to push/remove?

    Why does the BLTouch don´t have Power? (LED is lighten)



  • @justd said in BL-Touch and the Duex 5:

    Error: G0/G1: insufficient axes homed"

    https://duet3d.dozuki.com/Wiki/FAQ#Section_I_get_this_error_message_Error_G0_G1_insufficient_axes_homed

    You'll need to modify your homing files to add S2 to any G1 moves that attempt to move an axis before it is homed.

    Can you post your homing files please?

    M558 P5
    Please change to P9 to use the BLTouch probe type.

    When you first power on the printer does the BLTouch pop the pin in and out?



  • Not sure if this matters at all but should the

    M307 H7 A-1 C-1 D-1 ; Disable heater 7 to free up PWM channel 5 on the Duex board.

    come before or after the

    M558 P5 H7 F500 T9000 X0 Y0 Z1:U1:V1:W1 ; Set Z probe type 9 to bltouch (P5 as Betrue3D) and the heater (7) height + speeds (+ B1)

    or does it not matter. Currently it is after.

    Regards,

    Sam


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.