FAN Duet3D WiFi connections ?



  • Hello.

    I am upgrading my Wanhao Duplicator I3 v2.1 with the Duet3D WiFi board. I am struggling to get the fans running and would appreciate some guidance.

    I currently have the Cooler fan set on one of the "Always on" pins. The Extruder Fan I have set on one of the PWM Fan slots. I have done this because the cooler always comes on when I power the printer, suggesting an "always on", where as the Extruder Fan only comes on during printing and at varying rates.

    At the moment neither fan is working or can be controlled through the web control interface.

    Thank you in advance.



  • if the fan on the always on is not working then something is wrong.
    check that you have the polarity correct. connecting the fans the wrong way can actually damage the board.

    connect the fan directly to the power supply and see if they turn on.
    if they dont, they are broken.
    ifn they do your wiring was incorrect.



  • @veti That sounds a little worrying. I have checked the fan and it runs when connected directly to a 5v source. I have checked the continuity in both POS and GND cables, they are both fine. I have also checked both blade fuses - they look fine. I have double checked the polarity of the wiring and I see nothing obvious there.

    Have include an image, but I'm pretty sure that's how it's meant to be (always on is the fan), PWM is the extruder fan.0_1559071563584_FAN-Connections.png



  • for the left fan connector is that a black stripe on the right cable? if so thats the ground being connected to the vin pin.

    check the fan fuse if that is blown.



  • @veti said in FAN Duet3D WiFi connections ?:

    for the left fan connector is that a black stripe on the right cable? if so thats the ground being connected to the vin pin.

    check the fan fuse if that is blown.

    Wow, you are absolutely right. I have swapped the connectors and set the fan to 58% by way of test, now it is working as expected.

    Thank you so much, that's one more thing I can mark as "working".

    The "always on" is still not working but at least this is a step forward.



  • @b0m0a0k said in FAN Duet3D WiFi connections ?:

    I have checked the fan and it runs when connected directly to a 5v source.

    you have set to duet fan voltage to vin not 5v.



  • @veti Hi. Very much appreciate all your help by the way.

    If I swap the jumper to 5v the extruder fan stops responding. If I put it back to VIN it works just fine again.


  • administrators

    What voltage(s) are the fans?



  • @dc42 Sorry, missed your post. Both these fans are 12v 0.12A. They are the factory fans. Two pin.0_1559078913248_FAN type.png



  • does the fan work on any of the other connectors?



  • @veti Hi. Will try that when I get back in front of the printer later. I was a little nervous about connecting it to any of the PWM slots because I'm not sure it's rated for that sort of thing. I am now hyper about damaging the board by connecting something the wrong way. I guess if I get backed into a corner and it's just not working I could supply the voltage from a buck converter and bypass the board connections altogether. The was working when connected direct to a power source so it shouldn't be the fan, however, I have a new one arrived today and I will try that as well later.

    None of the fuses look blown, however, I have seen fuses that presented as not blown only to find that there was some mechanical fault that made the fuse useless. I have some mini blade fuses so (if I have the correct rating) may try swapping them out. I can also pull the three board fuses and run a continuity check on them just to be sure.



  • @b0m0a0k said in FAN Duet3D WiFi connections ?:

    I could supply the voltage from a buck converter

    Are you saying you have a 24v Supply and 12v fans?



  • @veti These are 12v fans. The picture of the fan is a couple of comments above.



  • @b0m0a0k
    i am asking about your power supply. or why else would you want to use buck converters.
    which would mean that you are currently running your 12v fans with 24v.



  • @veti I'm thinking about my options if I can't get this fan to power directly from the board. If something is going on with the "always on" pins and I can't plug the fan into the PWM (because I don't know if the fan is rated for that) then may be I can do a workaround by supplying the 12v from somewhere else. That fan doesn't seem to do anything other than run when the printer is powered.



  • Can you please describe what your power voltages actually are. In this thread you've mentioned 5v, 12v, and 24v. It appears the fans are 12v? What is the voltage of the power supply?

    Most fans will work just fine with the PWM ports on the Duet. It switches the negative leg and you can modify the PWM frequency to suit the fan.

    If your power supply is 24v and the fans are 12v you can use the Vfan jumper pin to feed a separate 12v supply from a buck converter to just the fan pins.

    https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans



  • I resolved this issue last night. It turned out to be a dry solder connection in the cabling. This fan is now running as expected on one of the "Always On" connectors. Thank you again to everyone who took the time to try and help out. It's much appreciated.


Log in to reply