IR Z Probe Settings



  • Hello again.
    I had to switch to a microswitch Z stop for a while, but now i am putting the IR probe back to work. I have it mounted, and wired. It triggers just fine, and the Duet can read it. However, it triggers at 1.25mm above the bed like it should and I cant seem to set the Z offset so that it moves on down to zero. It stubbornly sticks to the Z height being exactly where it triggers the IR probe.
    This seems like its a leftover setting from the Z probe time, But I am not able to tell where. I will attach my config.g and homeall.g files here, so you can point out what i missed.

    Config.G:
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 26 2019 22:23:49 GMT-0600 (Central Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AMV8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Awesome Sauce!" P"1q2w3e4r" I10.0.42.195 J10.0.42.1 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X32 Y32 Z32 E32:32 I0 ; Configure microstepping without interpolation
    M92 X160.00 Y160.00 Z845.00 E768.00:768.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00:1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z250.00 E250.00:250.00 ; Set accelerations (mm/s^2)
    M906 X1200.00 Y1200.00 Z1200.00 E900.00:900.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    M564 H0 ; Allow movement without homing

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X250 Y280 Z270 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops
    M591 D0 P2 C3 S1 ; Set E0 endstop to filament runout microswitch on E0
    M591 D1 P2 C4 S1 ; Set E1 endstop to filament runout microswitch on E1

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X10 Y0 Z1.25 ; Set Z probe trigger value, offset and trigger height
    M557 X30:200 Y30:240 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool


    Homeall.G:
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 26 2019 22:23:49 GMT-0600 (Central Standard Time)
    G91 ; relative positioning
    G1 Z10 F6000 S2 ; lift Z relative to current position
    G1 S1 X-225 Y-285 F3600 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-225 Y-285 F1000 ; move slowly to X and Y axis endstops once more (second pass)

    G90 ; back to absolute mode
    G1 X140 Y140 F36000 ; put the head wherever you want it to be when you home Z (omit this line if it doesn't matter)
    G91 ; relative mode
    G1 S1 Z-300 F700 ; move Z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0 ; tell the firmware that we are at Z=0
    G1 Z5 F500 ;lift Z a bit

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @jkaechler said in IR Z Probe Settings:

    G1 S1 Z-300 F700 ; move Z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0 ; tell the firmware that we are at Z=0

    If you're wanting to use a probe to home, you will need to change this section to a G30 probe command.


  • administrators



  • That works! thanks.
    Now my next challenge. When I try to run bed mesh compensation, it moves to the first probe point, and then on down to the bed. But the Z keeps going down, the probe lights up but does not trigger. After a couple seconds DWC will report 'Z axis did not trigger' and abort the auto bed compensation run.

    What do i have wrong on this one?

    P.S. Phaedrux and DC42, thank you both for many answers and tips over the past year or so.



  • Happy to help.

    Are you saying that the probe works when homing but not when doing G29?

    Double check these guides

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe


Log in to reply