Z axis issues again.



  • As Requested

    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.03RC4 (2019-05-29b4)
    Web Interface Version: 1.22.6
    0_1559572747491_homeall.g
    0_1559572755385_homez.g

    Regards,

    Paul



  • This is on your Ender 3 pro?

    Are you heating the bed to temp before probing?

    The Ender bed has a tendency to warp a bit from heating.

    Can you post your config.g file so we can see what your probe settings are? There are a few changes you can try for the BLTouch to make it more consistent.



  • @Phaedrux Thanks for joining in.
    Yes it is on my Ender 3 Pro.
    I do all levelling and bed mesh with it at room temp, so no heaters on, as recommended by one of the tech people, just incase it affects the BL Touch.

    I printed 4 Thumb wheels from the Railcore download and they look ok.
    Printed some test bits and the last piece came out poorly.

    Waited an hour and I had to add +0.37 to Z height.
    Ran 5 manual probes with a result of 0.340
    Changed G31 and will try again!

    0_1559586213567_config(3).g

    Regards
    Paul



  • I think you should level it, home it, and run the mesh compensation routine with the bed at temperature. And measure the trigger height with both the bed and nozzle at temperature. Basically try to mimic printing conditions through out because things expand and change shape when heated up.

    You're correct that the current from the bed heater may affect the BLTouch, but rather than probing cold, you can add a switch to the M558 command to disable the heater only during the brief window the probe is actually being used.

    From your config:

    M558 P9 H5 F120 T6000                        ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X40 Y-13 Z0.340                     ; Set Z probe trigger value, offset and trigger height
    

    Try M558 P9 H5 F120 T6000 A10 R0.75 S0.003 B1

    This should increase the reliability of the BLTouch hopefully. You might notice it probe a few more times in a row than before, because it will now need at least 2 consecutive probe results to match within a tighter tolerance. This will help reject individual outliner results. It will also turn off the heaters during the probe move and turn them back on right after, so it will be kept at temp.

    Also, for your G31, try: G31 P25 X40 Y-13 Z0.340

    A trigger height of 0.34 seems abnormally low for the BLTouch. The BLTouhc instructions indicate that the base of the probe body should be ~8mm above the tip of the nozzle. And this should result in a trigger height of ~2mm.

    Also, when measuring the trigger height, instead of using a piece of paper to get the nozzle close, see if you can use your eye to get the nozzle to be just touching the bed. Then move the print head so that the BLTouch pin will be hitting that same spot. That should give you the most accurate trigger height measurement.



  • Thank you @Phaedrux I appreciate yours and everyones assistance.

    For your info, I levelled up before my last print adjusting Z, I admit I did not run the mesh, i forgot and it was at room temp.
    It printed badly.
    Have not turned printer off, Z to 0 and I can get the paper between the nozzle and the Mirror Glass bed. Have moved Z down to -0.40 from where I originally set it, the bed temp was approx 50, nozzle 120

    I will do as you ask and report back.
    Thank you again.

    Regards,
    Paul



  • Quick update.
    Have jogged nozzle to bed, measured from bed to body of BL Touch and it is 8.22mm

    Regards
    Paul



  • Heated Bed, jogged nozzle to a piece of paper, removed paper and jogged down again, -0.40 to get nozzle down.
    Ran G90 Z0
    Turned on HotEnd to my PLA temp of 205.
    Got a 'Z Probe readings not consistent'.....
    Some points get probed 2 or 3 times, some 8 or 9....
    I will check the wiring tomorrow. I have a join in the loom for the BLTouch.

    Thanks again all.
    P.



  • @paulhew assuming you're using the m558 line I suggested above, the probe results not consistent would mean that your probe results are varying more than 0.003 and it can't get two good probe results. The repeated probes you're seeing is it retrying. You can increase the tolerance value in m558 to make it less strict and accept the variation. It still may be less than you were getting before.

    The BLTouch shouldn't be that inconsistent though. Perhaps the pin needs to be cleaned?

    You could also try reducing the probe dive speed with M558 F60.

    The ender 3 pro has a magnetic bed and I'm wondering if it's having an effect. You could test this by placing a large book on the bed and then probing the book. If it manages to probe each point in only 2 or 3 attempts on the book then perhaps it's the magnets that are interfering.



  • Morning @Phaedrux .
    I used your code suggestion as I really want to resolve this.
    I do not use the magnetic bed, but either a mirror tile or the Boro... glass

    These were my last results of manual probing. Obviously 0.
    0_1559624891847_931a08e5-65de-48dd-967d-88e7585e89e6-image.png

    This morning I have changed to the dupont connectors going to the BLT to soldered wire which did not help the issue.
    I also have ordered another BLTouch.

    Going back to manual mesh bed levelling as I need to print something urgently for a charity.
    I have looked at all of my files from the backup I took before putting on the BL and made changes, but I do not know if it is right as it is asking me to move the Z Height.

    Please could someone check as I need to do Manual Mesh Levelling by adjusting the screws on the bed and I have 20 badges to print for a special needs school.

    0_1559634274647_bed.g
    0_1559634287587_config.g
    0_1559634325691_deployprobe.g 0_1559634500714_homex.g
    0_1559634357382_homeall.g

    Regards,
    Paul.


  • administrators

    Personally I wouldn't choose a value as low as 0.003 for the M558 S parameter, because that's much more accurate than you need and possibly less than 1 microstep resolution. Try 0.01 or 0.02.



  • Thanks @dc42
    Most points are 2 some are 3 and even 7 or 8 times.

    Takes a while to probe bed is flat, thank goodness.

    Just trying a print and will update you good people later.

    Regards,
    Paul.



  • @dc42 said in Z axis issues again.:

    Personally I wouldn't choose a value as low as 0.003 for the M558 S parameter, because that's much more accurate than you need and possibly less than 1 microstep resolution. Try 0.01 or 0.02.

    Yes it's quite tight, but the idea was to highlight if it was having consistency issues, which it seems to have been.



  • I have a new V3 BLTouch that arrived today.
    Just need to finish printing these badges and then will test the new BLT to see if that makes a difference, then I will try PETG again........

    Regards, Paul.


Log in to reply