M558 with B1 and maintaining temp between probes



  • So M558 has the option to disabled bed while probing to prevent probe interference (this is good). Problem is I can't get it to allow me to maintain the temperature throughout a mesh bed leveling. Measuring cold could result in inaccurate mesh because of how the bed changes shape when it expands from heat. I tried adding recovery time, with the R option but it doesn't seem to turn the bed on while recovering so it makes it even worse.

    Is there a way to delay the probe to wait for the bed temps to recover before turning off the bed and probing the next point?


  • administrators

    You could reduce the travel speed (M558 T parameter) so that there is more heating time between probes.



  • That's working well, thank you.


  • administrators

    I'm glad it's working. The reason we keep the heaters off during the recovery time is that some probes (e.g. BLTouch) need to recover from the effects of the magnetic field generated by the bed heater.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.