Homing lost immediately



  • Hi,

    I've just upgraded my Duet WiFi from v1.21 to v2.03 after having it sit idle for 6 months. I've checked intermediate release notes and can't see anything to explain this behaviour, but I must have missed something!

    Problem: Once the homing sequence is finished (home all, or any axis individually), each axis 'Home' button is blue showing the homing is complete, then the the homed status is immediately reset.

    Attached are some images which show that all axes have their minimum endstop triggered, yet are also simultaneously showing they aren't homed. Visual inspection confirms that the endstops are triggered correctly, and the endstop lights on the Duet are on.

    2_1561789518268_Machine Properties.png1_1561789518268_Machine Control.png
    0_1561789518268_Firmware.png

    My 'homex.g' is a direct copy paste from the documentation for Cartesian documentation.

    Thanks,
    Craig


  • administrators

    I can't think of a reason why it should do that. The usual reasons for homing being lost are that you have used M18 or M84 to turn the motors off, or that the board has reset. If it has reset them you would probably notice DWC reconnecting, also the "last reset" info in the M122 report would give it away.



  • Thanks! I didn't realise M84 had that effect, is this functionality new from v1.21? I was expecting that if the endstops are triggered then the Duet should consider it is home, regardless of motors being on.

    In my config.g I have "M84 S0.5", and now that I've commented that out Home is maintained for the default 10 s, which allows me to enough time to hit run on a mesh grid.



  • @waley When you disable the motors, there is no holding current so it would be very easy for the printer to lose position. Hence the reason why homing status is reset. AFAIK, the firmware has always worked like that.



  • @deckingman that's a good point, still I would have expected endstops to suffice, but I guess that alone isn't repeatable enough. I must have inadvertently been slicing with different settings before, which would be why I hadn't noticed it.


Log in to reply