Duet Ethernet not working



  • When trying to configure the duet 2 ethernet board and connect it to my network I have run into multiple issues, mainly that when I do the M552 command in YAT I get a response of 'Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0<LF>ok<LF>' which I am aware that 0.0.0.0 isnt a valid IP address and I am wondering if you have any suggestions on how to fix this issue?

    From what I can tell it is due to the ethernet port on the board not being active but I have tried every command I am aware of to activate it but no luck.



  • I do not remember what the command is, but try to enable DHCP.... If you haven't already. If that doesn't work, hard set the IP (static) and see if you can ping that IP.
    Also, a good question is, do you see blinking lights on the Ethernet port when it's plugged into the switch? Do you also see lights on the switch port it's plugged into?



  • I dont see any lights on the ethernet port, as far as I can tell DHCP is enabled, unsure how to set a static IP so will have a look into that, this printer is going to being moved around quite alot to different networks so unsure if that is going to be a good fix for me as having to set a new static IP every time will be a hassle.



  • @bewaren
    If the network cable is plugged in to switch and Duet2 (switch powered on), then the lights should be working even if the IPs are wrong data doesn't properly work.
    Make sure all the connections are good and you have a good working cat 5, 5e or 6 cable. (Other cable standards would work too, those are just the most common). If the lights are not on (or blinking), you most likely have a physical issue. (Layer 1 of the OSI model).



  • Alright, strange solution as I had tried 4 different ethernet cables and none of them worked so I have just wired up a new one to an RJ45 and it is working, guess something was wrong with the other cables I was using.



  • Setting the IP address to 0.0.0.0 will enable DHCP.


Log in to reply