Upgrade from 1.22.6 to 1.24 Has Goosed *.local addressing.



  • Hi All,

    Having issues with a duet v0.6 that has stopped talking to the network.

    I've tried different leads and disconnected a dc42 IR probe that i had just swapped in on a different fault diagnostic. Here is the M122 response. Any ideas? I will try bossac loading the firmware again, and double check release note to ensure I hadn't missed anything between 1.22.6 and 1.24.

    === Diagnostics ===
    RepRapFirmware for Duet version 1.24 running on Duet 0.6
    Used output buffers: 2 of 16 (2 max)
    === System ===
    Static ram: 44204
    Dynamic ram: 42580 of which 3328 recycled
    Stack ram used: 1080 current, 2452 maximum
    Never used ram: 5740
    === Platform ===
    Last reset 00:07:15 ago, cause: power up
    Last software reset at 2019-07-27 07:22, reason: User, spinning module GCodes, available RAM 4300 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0400f000 BFAR 0xe000ed38 SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 21.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 37.9, current 58.2, max 58.6
    Date/time: 1970-01-01 00:00:00
    Slowest loop: 0.32ms; fastest: 0.10ms
    I2C nak errors 24, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 24
    === Move ===
    Hiccups: 0, FreeDm: 100, MinFreeDm: 100, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Free connections: 16 of 16
    Free transactions: 24 of 24
    Locked: 0, state: 4, listening: 20071bf4, 0, 0
    ok



  • Just seen this on startup. Bug?

    Done!
    RepRapFirmware for Duet is up and running.
    Network up, IP=192.168.85.113
    Bad command: Done!
    ok
    Bad command: RepRapFirmware for Duet is up and running.
    ok
    Bad command: etwork up, IP=192.168.85.113
    ok



  • Odd, my .local address doesn't work but the IP address does...

    wesbrooks@shlapentop:~$ ping ormergog.local
    ping: ormergog.local: Name or service not known
    wesbrooks@shlapentop:~$ ping 192.168.85.113
    PING 192.168.85.113 (192.168.85.113) 56(84) bytes of data.
    64 bytes from 192.168.85.113: icmp_seq=1 ttl=255 time=0.159 ms
    64 bytes from 192.168.85.113: icmp_seq=2 ttl=255 time=0.240 ms
    64 bytes from 192.168.85.113: icmp_seq=3 ttl=255 time=0.197 ms
    64 bytes from 192.168.85.113: icmp_seq=4 ttl=255 time=0.276 ms
    64 bytes from 192.168.85.113: icmp_seq=5 ttl=255 time=0.230 ms
    64 bytes from 192.168.85.113: icmp_seq=6 ttl=255 time=0.198 ms
    64 bytes from 192.168.85.113: icmp_seq=7 ttl=255 time=0.226 ms
    64 bytes from 192.168.85.113: icmp_seq=8 ttl=255 time=0.211 ms
    64 bytes from 192.168.85.113: icmp_seq=9 ttl=255 time=0.228 ms
    ^C
    --- 192.168.85.113 ping statistics ---
    9 packets transmitted, 9 received, 0% packet loss, time 8200ms
    rtt min/avg/max/mdev = 0.159/0.218/0.276/0.033 ms
    wesbrooks@shlapentop:~$ ^C
    wesbrooks@shlapentop:~$



  • Network section of config.g:

    ; Network
    M550 P"OrmerGog" ; Machine name (can be anything you like)
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xF0 ; MAC Address
    M552 P0 ; IP address (0 = use DHCP)
    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet



  • Tried the following with no luck. Access via IP address still works fine, ormergog.local doesn't. Now rolling back to 1.22.6.

    ; Network
    M550 POrmerGog ; Machine name (can be anything you like)
    M540 PBE:EF:DE:AD:FE:F0 ; MAC Address
    M552 P0 S1 ; IP address (P0 = use DHCP, S1 = Enable Networking)
    M554 P192.168.85.1 ; Gateway
    M553 P255.255.255.0 ; Subnet mask
    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet



  • Currently running Duet Web Control 2.0.0-RC6.



  • .local addressing works fine on 1.23 (2018-12-24b1) .


  • administrators

    The MDNS support in the LWIP TCP/IP library was crashing RRF on some user's machines. On investigation I found the that MDNS code was pile of junk, with error checking missing in multiple places, causing buffer overflows and/or null pointer dereferences - hence the problems. So MDNS support was removed in version 1.23. See https://forum.duet3d.com/topic/8352/duet-0-6-randomly-reboots/5.

    Anyone interested in fixing RRF to reinstate this functionality should consider upgrading the version of LWIP used by RRF to version 2.



  • Argh! Ok, fair enough. I'll have to sort out the mac address IP reserves on the router again.

    That is really easy to miss in the release notes if you had no idea what MDNS is.


  • administrators

    I've updated the upgrade notes to mention ".local" addressing.


Log in to reply