Machinename.local not working (from one day to another)



  • Hello guys,

    I always connected to the printer via machinename.local. The name is set up in the config.g file. At first I needed to install the bonjour-services (from Apple) to get it to work. Now it was working for half an year and from one day to another it stopped working. I still can connect to the board via the IP adress. The thing is, that I can't set a static IP in the router so the adress is changing every 30 days (which is really annoying).

    I tried to update the bonjour service but I had no luck.
    Any suggestions?

    Best Regards



  • For me as well, the machinename.local has never worked. If i type that into my browserbar, it just googles it.



  • @nitrofreak said in Machinename.local not working (from one day to another):

    For me as well, the machinename.local has never worked. If i type that into my browserbar, it just googles it.

    try machinename.local/ to prevent chrome from doing a google search. (note the trailing slash)

    mdns like this also requires client support, and for windows the easiest choice is apple bonjour for printing.

    (of course the above probably doesn't apply if it stopped working)



  • Do you mean you don't have access to the router settings or the router doesn't have an IP Address reservation system?

    If the latter try restricting the IP Addresses the DHCP server uses to a specific range (eg 100-254) and set the duet to use a static IP address (somewhere in the 2-99 range for previous example).



  • @taconite said in Machinename.local not working (from one day to another):

    Hello guys,

    I always connected to the printer via machinename.local. The name is set up in the config.g file. At first I needed to install the bonjour-services (from Apple) to get it to work. Now it was working for half an year and from one day to another it stopped working. I still can connect to the board via the IP adress. The thing is, that I can't set a static IP in the router so the adress is changing every 30 days (which is really annoying).

    I tried to update the bonjour service but I had no luck.
    Any suggestions?

    Best Regards

    have a look at this thread https://forum.duet3d.com/topic/11425/upgrade-from-1-22-6-to-1-24-has-goosed-local-addressing/7



  • @doctrucker Thank you for your reply!
    I have access to the router but is doesn't have a reservation for IP's.
    I tried this, cause I read it on another tread. the DHCP range is from .1 to .199 so I tried 205. If i just send the M587 command it replys the new IP address.

    But:
    I can still reach the duet over the old IP assigned by the router (.114). So now the big question is If i have to delete the old IP address from the routers memory?



  • @bearer currently I am using Version 2.02 of the Firmware
    " FIRMWARE_VERSION: 2.02RC5(RTOS) ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2018-11-28b1
    and I did no Upgrade. Maybe I miss something but it just stopped ....



  • Thats a bit strange then, my money would be on client side trouble if you didn't change the firmware. Try wireshark to log the traffic and see if you can see the request from your computer and response from the duet?

    I've more or less given up on bonjour and made sure I have a router that can do proper dhcp/dns.



  • I have always found .local hit and miss with any device but my router names hosts it gives DHCP leases to .lan. So machinename.lan works for me and doesn't require anything on the client side.



  • I have a number of devices, beyond the Duet, that have mDNS (the open equivalent to Bonjour).

    Windows machines trying to find "real" Bonjour machines, and/or mDNS machines, are very flakey. Apple machines, both osX and iOS, are close to perfect.

    So... I quit using it in mixed environments.

    P.S. Check out the Chrome store for a couple of plugins that will show all mDNS info for the machine on which Chrome is running. Very helpful, if someone does intend to continue to pursue this.



  • had to do some wiring to test against Duet2Maestro, maybe the windows command line tool that comes with Bonjour may kickstart things.

    dns-sd -G v4 hostname

    (at least forcing it to browse for _arduino_.tcp services seems to help platformIO with OTA stuff when it gets cranky. Seems solid on Linux, but Windows is a lottery).

    @Danal which plugin? Searching for mDNS didn't seem to get any matches to what you describe


  • administrators

    MDNS protocol is not currently supported on Duet Ethernet or Duet Maestro. It is supported on Duet WiFi.



  • Wow ... it seems like I found the issue. My machine name was (all the time when it was working and not working) e.g. xx-yy. Now I changed it to xxyy and not it is working like a charm again. Any ideas why this happens. There currently was a firefox update so maybe it has something to do with that



  • might have something to do with local search domain, but that would suggest mDNS never worked and your router is doing the DNS work

    (nope, read that as xx.yy not xx-yy so that would not affect the search domain)



  • the entire mdns name resolving is very fragile and should not be relied upon.

    i would suggest to see if your router is supported by openwrt and flash that. or consider replacing your router with one that supports alternative firmwares.
    this has multible benefits.
    you have a lot more configuration options
    more secure than as it does get security patches.

    i personally run a small machine with a celeron (which uses 6 watts) as my router running ipfire.
    the name resolution is done via dns, so for me it does not rely on mdns and it work even on machines that do not support mdns



  • mikrotik routes have build in DNS server.
    And they have a lot options more, good solution for some with doesn't like fiddling around with alternative firmware. The basic/normal models doesn't cost more then a regular good router.



  • I would think its safe to say any consumer or nat capable router has built in dns server, what sets them aside is the dhcp and dns server talking to each other (or in the case of openwrt w/dnsmasq, being the same server daemon)


Log in to reply