Setting up wifi on Duet Wifi



  • I have a problem adding / modifing the wifi on my Duet 2 Wifi. I get following message:

    0_1564516371366_123.PNG

    Any suggestions on what I did wrong? It was working fine previously but I got a new router and had to setup everything again.

    Greets
    Max



  • Not familiar with the Duet Wifis, but recall there is an issue if your SSID is hidden?

    And I know in general the ESP8266 wifi isn't compatible with all of the latest encryption schemes, but I don't recall of the top of my head which doesn't work.

    Add information about your wireless network, everything but the key please, and someone might know more.



  • @bearer said in Setting up wifi on Duet Wifi:

    Add information about your wireless network, everything but the key please, and someone might know more.

    I don't know if that is the problem - the Duet Wifi will connect with the same wifi repeater as before, only the Password is different:
    Wifi SSID: Wirless Witichis Repeater
    Frequency: 2,4 GHz
    Encryption: WPA2

    If you need any other information say so - I am not really good with networking 😄

    I don't know what happend and what "bad reply format version" means.

    Greets
    Max


  • administrators

    Try using M588 S"*" to delete the existing known networks before you use M587 to add the new one. Also please tell us the main firmware and WiFi firmware versions you are using.



  • @dc42
    I tried
    M588 S"*"

    I get the same response with "bad reply format version". I can't access DuetWeb Control - where can I get the firmware + Wifi Version numbers?

    Greets
    Max



  • If you've updated your firmware recently, it may have got out of sync with the supported version of the Wifi firmware. Sending M122 will produce the Diagnostic report. In that there will be the RepRapFirmware version:

    >>>m122
    SENDING:M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.04RC1 running on Duet WiFi 1.0 or 1.01
    

    and in the last section under '- WiFi -' will be the WiFi firmware version:

    WiFi firmware version 1.23
    

    This report doesn't show the version of the Duet Web Control. To update the Duet firmware, WiFi firmware and DWC version, see https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware

    Ian



  • I got it working now.

    Is it possbile, that I have to de-activate the wifi module (M552 S0) befor I use M587 S"..." P"..."? I use M552 S1 in my config.g as standard.

    What I did to solve the problem:

    • update to the most recent firmware --> did not help
    • restartet the printer multiple times --> did not help
    • disabled wifi with M552 S0, removed all previous connections with M588S"*", added new connection with M587 S"..." P"...", enabeld wifi using M552 S1

    Now it works fine.

    Have a nice weekend,
    Max


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.