WiFi module won't start



  • Hi!

    Recently my Duet WiFi 2 Board v1.04 couldn't connect to my WiFi. It was some time ago but I think I wanted to update to version 2.03 and then it lost the connection. When I turn on the my printer, the blue WiFi LED doesn't do anything. So I connected the Duet board to my PC to get connected to my WiFi again but I can't get it work. The Wifi module just won't start.

    When I send command M552 it says: WiFi module is being started. But nothing happens. The blue LED is always off.
    M552 S0 only gives me a "ok".
    M552 S1 gives me "Turn off the current WiFi mode before selecting a new one; ok". (What does this mean?)
    M552 S-1 gives me "WiFi module stopped; ok".
    When I want to enable the WiFi connection again with M552 S1, the blue LED blinks like for 0,1 sec and goes off again.

    What do I do wrong? Is it the update to version 2.03?


  • administrators

    Depending on what firmware version you were running before, you may need to update the WiFi firmware too. So download version 1.23 of DuetWiFiServer.bin and use a PC to copy it into /sys on the SD card. It must be called exactly DuetWiFiServer.bin on the SD card. Then put the SD card back in the Duet, power up the Duet, and send M997 S1 from YAT or PanelDue. Monitor the progress messages to make sure that the WiFi firmware installs correctly.



  • @dc42
    Yes it seems like it didn't install the server version correctly. I replaced all the files on the SD card and installed everything manually and now it works.
    perfect! thanks

    can't find the "topic solved" button.. Is there one?



  • @christoph13524 said in WiFi module won't start:

    can't find the "topic solved" button.. Is there one?

    first make the topic a question, then mark as solved. its not immediately obvious no.
    0_1564822723976_850307dc-f2db-48d1-be01-dce62db34567-image.png


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.