Duet 2 meastro 2 Z motor problem



  • I moved this to a new topic from Duet 2 maestro problems

    I did get the x and y moving good and homing good now.. did have a wiring problem

    but still having a Z problem there moving real slow, and it looks like they are moving in the opposite direction of each other..

    I am trying to use E1 for the second Z motor and Z or the first Z motor..
    here is my config again, from reading different messages it seems like I have to use E3
    for the motor mapping and was also told to used E1 any help here please..

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Jul 02 2019 13:29:03 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"mycartiesan" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes forwards
    M569 P1 S0 ; Physical drive 1 goes forwards
    M569 P2 S0 ; Physical drive 2 goes forwards
    M569 P3 S0 ; Physical drive 3 goes forwards
    M569 P4 S1 ; Physical drive 3 goes forwards
    M350 X32 Y32 Z32 E32 I0 ; Configure microstepping without interpolation
    M92 X200.00 Y200.00 Z200.00 E420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X3000.00 Y3000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X400.00 Y400.00 Z400.00 E400.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M564 H0
    M84 S30 ; Set idle timeout

    ;Dual Z
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1
    M671 X-20:330 Y0:0 S0.5 ; leadscrews at left and right of X axis
    M208 X-5:325 Y0:325 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200
    ;

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z330 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 I1 R0.4 H5 F1200 T6000 ; Set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:300 Y15:300 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T97700 B3950 R2200 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R2200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    Thanks gary



  • @gorf26 said in Duet 2 meastro 2 Z motor problem:

    M350 X32 Y32 Z32 E32 I0 ; Configure microstepping without interpolation

    why would you not enable interpolation?

    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping
    you ignored the section about the order

    M92 X200.00 Y200.00 Z200.00 E420.00 ; Set steps per mm

    Z200 is most likely wrong and the reason why your z axis is moving so slow.

    If you have a 4 start T8 leadscrew, you need Z800



  • Thanks think I have the 2 motors working ok and the x and y now

    I have one issue I thought I had it setup to use the probe for homing
    that doesn't seem to be working..

    I do have a home switch on the z also that is working but not the probe as a home switch..
    so I must be missing something there also..

    Ok thanks M92 go's after M584 from what I am reading

    also when I home x or y the Z move down a few mm then the x or y homes and the z moves back up a few mm is this normal?.

    Thanks gary



  • @gorf26 said in Duet 2 meastro 2 Z motor problem:

    I do have a home switch on the z also that is working but not the probe as a home switch..
    so I must be missing something there also..

    dont use switch + probe. it just makes it more complicated.

    also when I home x or y the Z move down a few mm then the x or y homes and the z moves back up a few mm is this normal?.

    yes its the default for files generated from the configurator.



  • @veti
    so I am assuming now I remove the Z1
    from M574 X1 Y1 Z1 S1
    I modified the homeall and homes
    and added the G30
    Haven't test but will tomorrow..

    Thanks



  • @gorf26 said in Duet 2 meastro 2 Z motor problem:

    so I am assuming now I remove the Z1

    you change it by adding
    M574 Z1 S2 ; Set endstops controlled by probe



  • @veti

    Thanks that worked OK do I need to set G92 Z0 also

    also it looks like my extruder is set correct but I get no movement
    I sent a g302 p1 first but no motors
    getting the message attempting to extrude with no tool selected..

    I have tried g01 e100 t0 but on luck..
    So guess I have something misconfigured again..

    It does look like the E0 endstop is on yes..
    could that be the problem..
    Gary



  • add this to the end of your config.g

    ; Miscellaneous
    T0 ; Select first tool

    Thanks that worked OK do I need to set G92 Z0 also

    no that makes no sense. what kind of lead screw do you have?



  • its one I had laying around if I remember right its a 3/8 - 12

    I have the z motors moving haven't checked if they are moving the right distance yet but they are moving together...

    I did get the probe to work for z home also, but I don't think it set the bed to z0

    my main problem right now is no extruder movement even with a m302 p1

    if I check the status it shows that the E0 switch is triggered..
    I assume that's my problem I just don't see anything in the config that bad
    but I still learning..

    Gary



  • @gorf26 said in Duet 2 meastro 2 Z motor problem:

    its one I had laying around if I remember right its a 3/8 - 12

    well guessing is not going to cut it here. you need to know this exactly to calculate the steps per mm or you wont be able to print correctly.



  • @veti

    I know that not to worried about the steps per right now I want to get all the functions
    working then I'll fine tune it...

    and right now the extruder motor isn't moving, and don't see any reason why in the config.



  • what the output in the console if you put in G0 E1?



  • Thanks I got it work, was a typo..

    So now I will calibrate it..


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.