Cura settings



  • I have my ender 3 setup with a new computer and am using Cura as my slicer. I have configured the printer and the Duet wifi to home in z with a ir probe. The problem is that when I slice and send the Gcode to Duet from Cura it will not pick up my homing settings that are on the duet and moves slow to the homing points,but worse it will not move the x or y over to allow the z prob to be over the bed plate so it crashes into it. How do i tell it to do the same in Cura as it does in Duet. If that makes any sense.



  • @dumbo Your homing files on the Duet are the problem.

    For example; for homing Z, you move the prob to a safe location. On mine, I use the center of the bed.



  • What are your setting if I can ask. Did you delete your homing files in the Duet confi folder?



  • Can you post your homing files from the duet and the starting gcode script from Cura?



  • cura settings
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate

    G28 ;Home

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    Duet Settings for z
    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon May 06 2019 00:09:50 GMT-0600 (Central Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 X50 Y50 ; Move over for Z probe referance
    G1 S1 Z-265 F1800 ; move Z down until the endstop is triggered
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 S2 Z5 F100 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X0 Y0 F6000

    Thanks



  • @dumbo said in Cura settings:

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    You'll likely need to specify relative or absolute positioning for these moves with G90 and G91



  • @dumbo You keep homex.g, homey.g, homez.g and homeall.g in order to home the axes via G28.

    My current homing files:
    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Oct 06 2016 12:46:23 GMT-0400 (Eastern Daylight Time)
    ; Lift Z relative to current position
    G91
    G1 Z5 S2 F9000
    ; Move quickly to X axis endstop and stop there (first pass)
    G1 X-405 F3000 S1
    ; Go back a few mm
    G1 X5 F9000
    ; Move slowly to X axis endstop once more (second pass)
    G1 X-405 F360 S1
    ; Lower Z again
    G1 Z-5 S2 F9000
    G90

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Oct 06 2016 12:46:23 GMT-0400 (Eastern Daylight Time)

    ; Lift Z relative to current position
    G91
    G1 Z5 S2 F9000
    ; Move quickly to Y axis endstop and stop there (first pass)
    G1 Y-305 F3000 S1
    ; Go back a few mm
    G1 Y5 F9000
    ; Move slowly to X axis endstop once more (second pass)
    G1 Y-305 F360 S1
    ; Lower Z again
    G1 Z-5 S2 F9000
    G90

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Oct 06 2016 12:46:23 GMT-0400 (Eastern Daylight Time)
    ; Lift Z relatively to current position
    G91
    G1 Z5 S2 F9000
    G90
    ; Go to center and home the Z axis
    G1 X200 Y150 F9000
    G30
    G1 Z0 ; go to Z0, use to help calibrate G31 Z offset

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Oct 06 2016 12:46:23 GMT-0400 (Eastern Daylight Time)
    ; Relative positioning
    G91
    ; Lift Z
    G1 Z5 S2 F9000
    ; Move towards X and Y axis endstops (first pass)
    G1 X-405 f5000 S1
    G1 Y-305 F3000 S1
    ;G1 S1 X-405
    ;G1 S2 y-305
    ; Go back a few mm
    G1 X5 Y5 F9000
    ; Move slowly to axis endstops once more (second pass)
    G1 X-405 F360 S1
    G1 Y-305 F360 S1
    ; Absolute positioning
    G90
    ; home the Z axis
    G1 X200 Y150 F9000
    G30



  • Thanks for the help I have changed a few things on you setup but getting there. Thank you very much


Log in to reply