Is my trigger height being ignored?

  • My BLTouch was calibrated and working well. I had to replace the nozzle, so I disassembled/reassembled my hotend and needed to re-calibrate the z-height. I followed the recommended procedure of:
    Move nozzle to bed using paper as test
    G92 Z0
    Move nozzle to 5mm
    G30 S-1
    Repeat - results (0.145) were consistent +/- 0.005 mm.
    Set trigger height in config.g like this:
    G31 P25 X28.5 Y-5 Z0.145

    Everything else was unchanged.

    What is strange is that the nozzle moves to 5.70mm after homing, instead of the 5.145mm as expected. And if I test after homing by moving the nozzle to G1 Z0, it presses into the bed. Backing it off to 0.55mm passes the paper test as originally measured. So it seems there's a 0.55mm difference applied to the trigger height. How can I trouble-shoot?

    Thank you!


  • check that the trigger height is set correctly

    under machine properties

  • Swap the order of these two lines in config.g

    G31 P25 X28.5 Y-5 Z0.145      ; Z probe trigger value, o
    M558 P9 H5 F100 R0.2 T2000 A5 B1  ; Set Z probe type/mode 9. 

    Probe type (M558 P9) should be defined before probe offsets are defined (G31 XYZ)

    What firmware version are you using? Have you recently upgraded?

  • Swapping the order of those two lines fixed it! Odd that it worked before, but it is now behaving as expected. Thanks!

Log in to reply