Duet 2 Ethernet keeps disconnecting

  • 0_1566051667717_CL.png

    I keep losing connection to the Duet 2 on our Tool Changer every 5 seconds or so. I've tried obvious things such as changing the Ethernet cable, the port, reinstalling 2.04RC1 (2019-07-14b1). I'm completely stumped, what would be your next step?

    M122 Report

    0_1566051944454_M122 1.PNG
    0_1566051950341_M122 2.PNG
    0_1566051958301_M122 3.PNG

    Unsure if this is a network problem at work.

  • Would've copied that - but keep disconnecting, it was infuriating 😂

  • administrators

    Might you have an IP address conflict? Have you configured the Duet to use a static IP or to use DHCP?

  • If you can't get to the bottom of it installing wireshark and providing a capture file of a session might provide some insight to where it goes t*** up.

    (please do any capture without any other software or browser tabs running to keep the data to a minimum, and also to avoid sharing anything potentially sensitive)

  • @dc42 Currently DHCP, for a static IP at work I'll have to talk to our IT guys - I'll try this Monday to rule out a conflict.

  • Also ask your IT guys, how long is the "Lease Duration" for the DHCP scope....

    What URL are you using to get to the web interface, are you putting in a name (so using DNS, which will usually require a static entry) or just using the IP address ??

  • DNS doesn't require a static entry unless your DNS and/or DHCP server is from the last millennium. Pretty standard to have DHCP update DNS records on the fly now.

    Until recently the Duet 2 even took care of its own mDNS resolution.

    Easiest way to test if the current DHCP setup is resulting in a IP conflict is to power down the Duet and see if the IP address responds to any sort of ping or other connections. Run nmap to be as sure as you can, the address could have a firewall silently dropping most or all packets so not a 100% test, but at the same time as good as you can do.

  • This was an interesting one - network problem, not the Duet. After a lot of troubleshooting, changing the MAC address that was associated with the static IP I had setup on the network solved the issue. Now I'll have to arrange for a new static IP, but interesting that this was the solution - the ping to the Duet was never interrupted. I think someone has made some changes to the network at work...

  • Thats interesting, most network equipment only cache the mac to ip mapping for a few minutes (with the exception of the dhcp server). Would be interesting to see if a new reservation causes new problems or if it was a one off.

Log in to reply