Macros don't show up on the PanelDue



  • I've got my PanelDue 7" connected to a DuetWifi and a Duex5 board. All the firmwares are up-to-date (PanelDue 1.15c, DuetWiFi 1.17c, DuetWebControl 1.14a, and DuetWiFiServer 1.03-ch). The issue is that the macros I have on the DuetWiFi microSD card don't show up on the PanelDue. I can see them on the web interface and they work perfectly. I have tried three different DuetWiFis and PanelDues, I ran into the same issue.

    There is also another thing that doesn't show up on my PanelDues. I have defined U and V axes. I can see the movement control buttons for U and V on the web, but not on the PanelDue. Does anybody have any idea why that happens?


  • administrators

    That sounds odd. Do the homing buttons for U and V show up on PanelDue? Please confirm that the M584 that create U and V are in config.g. Also check on the Setup page that the PanelDue firmware version running really is 1.15c.

    There are later firmware versions (1.18RC1 and 1.16beta2) but the versions you are using should work together.



  • I checked the firmware and it is 1.15c. Also, this the line I use in the config file to create U and V :

    M584 X0 Y1 Z2 U3 V4 E5:6:7:8:9 ; Create U and V axes

    I can see the the U and V homing buttons on the web interface, but not on the PanelDue.


  • administrators

    Does the machine name show up on PanelDue?

    Please try PanelDue firmware version 1.16beta2.



  • I upgraded the firmware. Still the same issue. Here are some pictures of the PanelDue and the web interface:


  • administrators

    Your temperature readings look odd and i am wondering whether your configuration is resulting in a status message that PanelDue is failing to parse. Please share your config.g file.



  • I've disabled the heaters in the config file. Please take a look:

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    M584 X0 Y1 Z2 U3 V4 E5:6:7:8:9 ; Create U and V axes
    M208 X0 Y0 Z-10 U-10 V-10 E0:0:0:0:0 S1 ; Set axis minima
    M208 X250 Y615 Z50 U400 V400 E1:1:1:1:1 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 U1 V1 E1:1:1:1:1 S0 ; Define active S0=LOW or S1=HIGH microswitches

    ; Drives
    M569 P0 S0; Drive 0 goes forwards
    M569 P1 S0; Drive 1 goes forwards
    M569 P2 S1; Drive 2 goes forwards
    M569 P3 S0; Drive 3 goes forwards
    M569 P4 S0; Drive 4 goes forwards
    M569 P5 S1; Drive 5 goes forwards
    M569 P6 S1; Drive 6 goes forwards
    M569 P7 S1; Drive 7 goes forwards
    M569 P8 S1; Drive 8 goes forwards
    M569 P9 S1; Drive 9 goes forwards

    M350 X16 Y16 Z16 U16 V16 E16:16:16:16:16 I1 ; Configure microstepping with interpolation
    M92 X320 Y320 Z640 U1066.66 V1066.66 E100💯100💯100 ; Set steps per mm
    M566 X500 Y500 Z1000 U300 V300 E1000:1000:1000:1000:1000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X5000 Y5000 Z1000 U1000 V1000 E1000:1000:1000:1000:1000 ; Set maximum speeds (mm/min)
    M201 X200 Y200 Z200 U200 V200 E200:200:200:200:200 ; Set accelerations (mm/s^2)
    M906 X1200 Y1900 Z800 U1600 V1600 E800:800:800:800:800 I20 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S60 ; Set idle timeout

    ; Heaters
    M307 H0 A-1 C-1 D-1
    M307 H1 A-1 C-1 D-1
    M307 H2 A-1 C-1 D-1
    M307 H3 A-1 C-1 D-1
    M307 H4 A-1 C-1 D-1
    M307 H5 A-1 C-1 D-1
    M307 H6 A-1 C-1 D-1
    M307 H7 A-1 C-1 D-1

    ; Detach Fans
    M106 P0 H-1
    M106 P1 H-1
    M106 P2 H-1
    M106 P3 H-1
    M106 P4 H-1
    M106 P5 H-1
    M106 P6 H-1
    M106 P7 H-1

    ; Network
    M550 PAAA ; Set machine name
    M551 Paaa ; Set password
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP


  • administrators

    Thanks, using your config.g file I can replicate the problem. Investigating now.


  • administrators

    It's a bug in DuetWiFiFirmware. Will be fixed in 1.18RC2.



  • Awesome. Thanks for your time and your responsiveness. I'm just wondering when you are planning to release 1.18RC2?


  • administrators

    @PayTor:

    Awesome. Thanks for your time and your responsiveness. I'm just wondering when you are planning to release 1.18RC2?

    Tomorrow I hope.


  • administrators

    I have just released version 1.18RC2.



  • I just updated the firmware to 1.18RC2 and the issue is fixed. Thank you so much for the help!


Log in to reply