Unable to connect to PanelDue, not showing in Windows



  • Hi,
    I bought my Duet 2 Wifi back in March from E3D and have been using it without much issue since. Today I went to print something and couldn't connect with the PanelDue. I decided to connect the board to my PC and even with nothing but USB connected I get nothing in device manager and can't connect to it via YAT or Bossa as the troubleshooting guides say. I have checked the SD card and there are no issues there. When I plug in the USB I get 4 lights, the green 3.3v led, 5v, diag and the led between the USB and reset button. Is there anything else I should try?
    Thanks





  • I've been through all of that and I still have nothing showing up ☹



  • You may need to reinstall your firmware. Have you erased and reset the board, installed the drivers and then tried Bossa?



  • @samlogan87 yes I have, unfortunately none of that worked.



  • seems the next step is to wait for one of the admins to approve a warranty replacement and contact e3d, as is the last step on the wiki.



  • Have you tried connecting via USB with the SD card removed? If there's something on the card (eg corrupt config.g) that's causing a reset loop, it won't show up in Windows. The diag light generally only comes on in a few instances: when the board is just starting up (so stays on if stuck in a boot/reset loop); when the reset button is stuck in so gets stuck in a boot loop (rare); when the firmware has been erased; or when the probe type is set to M558 P1 (in config.g, so removing the SD card should switch it off). You may need to do the firmware erase process a couple of times if the firmware has been corrupted, eg apply power, press erase button or put jumper on erase pins/remove jumper, press reset button or disconnect power.

    Check for any metal swarf or other possible short circuits around the reset button, and on the board in general. Also check if any components are getting hot (too hot to touch, be careful!) after 10 or 20 seconds , particularly the main processor and the voltage regulator U3.

    Ian



  • I have tried all you have suggested and nothing has changed. Nothing is getting hot and I cannot find any shorts.
    Thanks.



  • Is there anything else I can do or am I now waiting for an admin to confirm a warrenty return?
    Thanks all.


  • administrators

    I approve a warranty replacement. Please ask E3D for one and direct them to this post for approval.


Log in to reply